
<!DOCTYPE html><html lang="en"><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><meta name="viewport" content="width=1140, user-scalable=yes"><meta http-equiv="content-type" content="text/html; charset=UTF-8"><meta http-equiv="imagetoolbar" content="false"><meta name="robots" content="noodp,noydir" /><meta property="fb:app_id" content="196375740321" /><meta property="og:type" content="article" /><meta property="og:site_name" content="NBC 10 Philadelphia" /><meta property="og:description" content="Federal, state and local law enforcement agencies descended on the immediate area of West Turner Street near North Hall Street, prompting street closures and public transportation detours." /><meta property="og:title" content="Allentown Car Explosion Prompts Street Closures, Detours" /><meta property="og:url" content="http://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Prompts-Street-Closures-Detours-494735391.html"/><meta property="og:image" content="https://media.nbcphiladelphia.com/images/1200*675/Car_Explosion_in_Allentown.jpg" /><meta property="article:publisher" content="https://www.facebook.com/nbcphiladelphia" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbcphiladelphia" /><meta name="twitter:creator" content="@nbcphiladelphia" /><meta name="twitter:url" content="http://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Prompts-Street-Closures-Detours-494735391.html" /><meta name="twitter:title" content="Allentown Car Explosion Prompts Street Closures, Detours" /><meta name="twitter:description" content="Federal, state and local law enforcement agencies descended on the immediate area of West Turner Street near North Hall Street, prompting street closures and public transportation detours." /><meta name="twitter:image" content="https://media.nbcphiladelphia.com/images/1200*675/Car_Explosion_in_Allentown.jpg?ak=bc" /><meta http-equiv="last-modified" content="2018-09-30@01:45:45 EDT" /><meta property="fb:pages"content="96623207231"><meta property="fb:pages"content="296562883986"><meta name="tp:preferredRuntimes" content="Universal,HTML5" /><meta name="tp:preferredFormats" content="m3u,mpeg4,webm,ogg,flv,F4M"><meta name="keywords" content="local news, Philadelphia news, breaking news, South Jersey, Camden, Berks, Gloucester, Delaware, Montgomery, Chester, Bucks, Mercer, Atlantic, Ocean, County, Center City, South Philly, North East Philly, Philadelphia, Philly"><link rel="shortcut icon" href="https://media.nbcphiladelphia.com/designimages/favicon-phi.ico"><script type="text/javascript">
var win7ie = navigator.userAgent.indexOf('Windows NT 6.1') > -1 && (navigator.userAgent.indexOf('Trident') > -1 || navigator.userAgent.indexOf('MSIE') > -1);
if(win7ie) {
    var allMetaElements = document.getElementsByTagName('meta');
    for (var i=0; i<allMetaElements.length; i++) {
      if (allMetaElements[i].getAttribute("name") == "tp:preferredRuntimes") {
         allMetaElements[i].setAttribute('content', "Flash,HTML5");
         break;
      }
    }
}
// Stop older versions of IE from choking on calls to the console.
if(typeof console == "undefined") {

    console = {};
    console.log = function(msg) {
    // fail silently
    }

    console.warn = function(msg) {
    // fail silently
    }

    console.error = function(msg) {
    // fail silently
    }

    console.info = function(msg) {
    // fail silently
    }

}
</script><script type="text/javascript">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</script><script src="//www.nbcphiladelphia.com/includes/ads.js?r=-537853966" type="text/javascript"></script><!-- Facebook Pixel Code --><script>
    !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
    n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
    document,'script','//connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1655305654750814');
    fbq('track', "ViewContent");
    fbq('track', 'PageView');
        </script><noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=1655305654750814&ev=PageView&noscript=1"
    /></noscript><!-- End Facebook Pixel Code --><script type="text/javascript">
    var __csMarketIDValue = "1861572874";
    var __csMarketKeyValue = "67ed2dfc-f223-44f4-f9e9-6ebcf5490750";
  </script><script>
  var activateSharethrough = false;
  var shareThroughDesktopKey;
  var shareThroughMobileKey;
                var activateSharethrough = true;
      
 var shareThroughDesktopKey = "8xaegCvtABHg9YBYUiidUmii";
 var shareThroughMobileKey = "mBXcpjytWMYTFkQ5dxoQ4iMA";
      </script><script>
  var directSoldStyles = true;
  </script><script>
var fakeLoadMore = true;
</script><title>Allentown Car Explosion Prompts Street Closures, Detours  - NBC 10 Philadelphia</title><link rel="amphtml" href="https://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Prompts-Street-Closures-Detours-494735391.html?amp=y"><link rel="canonical" href="https://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Prompts-Street-Closures-Detours-494735391.html" /><meta name="sailthru.type" content="article" /><meta name="sailthru.description" content="Federal, state and local law enforcement agencies descended on the immediate area of West Turner Street near North Hall Street, prompting street closures and public transportation detours." /><meta name="description" content="Federal, state and local law enforcement agencies descended on the immediate area of West Turner Street near North Hall Street, prompting street closures and public transportation detours." /><meta itemprop="description" content="Federal, state and local law enforcement agencies descended on the immediate area of West Turner Street near North Hall Street, prompting street closures and public transportation detours."><meta name="sailthru.tags" content="allentown, car explosion, fbi, lantabus, transportation, street closures" /><meta name="keywords" content="allentown, car explosion, fbi, lantabus, transportation, street closures" /><meta name="news_keywords" content="allentown, car explosion, fbi, lantabus, transportation, street closures"><meta itemprop="keywords" content="allentown, car explosion, fbi, lantabus, transportation, street closures"/><meta itemprop="name" content="Allentown Car Explosion Prompts Street Closures, Detours"><meta name="sailthru.title" content="Allentown Car Explosion Prompts Street Closures, Detours" /><meta name="title" content="Allentown Car Explosion Prompts Street Closures, Detours" /><meta property="title" content="Allentown Car Explosion Prompts Street Closures, Detours"/><meta name="sailthru.date" content="2018-09-30 13:45:45" /><link rel="image_src" href="https://media.nbcphiladelphia.com/images/133*75/Car_Explosion_in_Allentown.jpg" /><meta itemprop="image" content="https://media.nbcphiladelphia.com/images/133*75/Car_Explosion_in_Allentown.jpg"/><link rel="stylesheet" href="//www.nbcphiladelphia.com/templates/nbc_global_styles.css?r=2065977975" type="text/css" /><script type="text/javascript">
    var thisIsAGalleryPage = false;
  </script><script src="//www.nbcphiladelphia.com/includes/third_party_plugins.js?r=1806176154" type="text/javascript"></script><script>
    var __mpsPlatform = "desktop";
        var mpscall = {
      "site"            : "local-web",
      "type"            : "Article",
      "content_id"      : "494735391",
      "cag[station]"    : "OTS",
      "cag[callLetter]" : "WCAU",
      "cag[feature]"    : "",
      "cag[region]"     : "Philadelphia",
      "cag[sensitive]"  : "false",
      "field[source]"   : nbc.referrer,
            "cag[tags]"       : "Morning Call Building|Federal Bureau of Investigation|Allentown|Alicia Lozano|Allentown Transportation Center|Morning Call|Cleveland Elementary School|car explosion|public transportation detours|Pennsylvania|transportation ",
      "cag[platform]"   : __mpsPlatform,
              "cag[stationtype]": "nbc"
          }
    var mpsopts = {
      "host":"mps.nbcuni.com",
      "updatecorrelator":true
    }
    var mps=mps||{};mps._ext=mps._ext||{};mps._adsheld=[];mps._queue=mps._queue||{};mps._queue.mpsloaded=mps._queue.mpsloaded||[];mps._queue.mpsinit=mps._queue.mpsinit||[];mps._queue.gptloaded=mps._queue.gptloaded||[];mps._queue.adload=mps._queue.adload||[];mps._queue.adclone=mps._queue.adclone||[];mps._queue.adview=mps._queue.adview||[];mps._queue.refreshads=mps._queue.refreshads||[];mps.__timer=Date.now();mps.__intcode="v2";if(typeof mps.getAd!="function")mps.getAd=function(adunit){if(typeof adunit!="string")return false;var slotid="mps-getad-"+adunit.replace(/\W/g,"");if(!mps._ext||!mps._ext.loaded){mps._queue.gptloaded.push(function(){typeof mps._gptfirst=="function"&&mps._gptfirst(adunit,slotid);mps.insertAd("#"+slotid,adunit)});mps._adsheld.push(adunit)}return'<div id="'+slotid+'" class="mps-wrapper" data-mps-fill-slot="'+adunit+'"></div>'};(function(){head=document.head||document.getElementsByTagName("head")[0],mpsload=document.createElement("script");mpsload.src="//"+mpsopts.host+"/fetch/ext/load-"+mpscall.site+".js?nowrite=2";mpsload.id="mps-load";head.insertBefore(mpsload,head.firstChild)})();
  </script><script type="text/javascript">
    // mmModule is now deprecated, do not add to object.
    mmModule = {}
    mmModule.omni = "nbcuotsdivisiontotal,nbcuotsphiladelphiatotal";
    nbc.omniture.suite = "nbcuotsdivisiontotal,nbcuotsphiladelphiatotal";
  </script><script language="JavaScript">
                  s_linkInternalFilters="javascript:,nbcphiladelphia.com,media.nbcphiladelphia.com,events.nbcphiladelphia.com,tsn.nbcphiladelphia.com,autos.nbcphiladelphia.com";
var nbcu_account="nbcuotsdivisiontotal,nbcuotsphiladelphiatotal";
var nbcu_prop8 ="nbc";
var nbcu_prop9 ="PHI";
var nbcu_prop10 ="WCAU";        nbc.callLetters = "WCAU";
    nbc.contentType = "";
  </script><script src="//www.nbcphiladelphia.com/includes/VisitorAPI.js?r=-1098718195" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/ots_dil.js?r=-1331500469" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/AppMeasurement.js?r=1525705316" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/nbc_global_common.js?r=-748994356" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/nbc_common_init.js?r=1680398388" type="text/javascript"></script><!-- Load the PDK from a relative domain --><script type="text/javascript" src="//www.nbcphiladelphia.com/assets/pdk587/pdk/tpPdk.js"></script><script src="//www.nbcphiladelphia.com/includes/video_caption_overlay_proof.js?r=1930995600" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/nbc_global_pws.js?r=-2024343032" type="text/javascript"></script><script>
    randomValue = "&rndm=" + Math.random()*10000000000000000;
    if ((U.readCookie("zipCode") && U.readCookie("zipCode") !== "") || U.readCookie("pwsSetDefault") !== null ) {
      if(U.readCookie("pwsSetDefault") !== null) {
        weatherZipCode = JSON.parse(U.readCookie("pwsSetDefault")).zip;
      } else {
        weatherZipCode =  U.readCookie("zipCode");
      }
      var marketZipCode = "19101"
          } else {
      weatherZipCode = "19101";
    }
    nbc.gptParams.pageData.zipcode = (readCookie("adZipCode")) ? readCookie("adZipCode") : weatherZipCode;
    nbc.weather= {
      validatedZip: "",
      adZipCode: weatherZipCode
    };

    var showLeaderboardAd = true;
  </script><script type="text/javascript">
    //<![CDATA[
    var videoAdContentGroup = "${videoAdContentGroup}";
    var videoadSiteKey =  "phi";
    var partnerID = "525842";
    var nbcfacebook = {
      connected: "no"
    };
                                        var _sf_startpt=(new Date()).getTime()
    // random number for ads
    var randDARTNumber=0;
    function genSetRandDARTNumber() {
      randDARTNumber = Math.round(Math.random()*1000000000000);
    }
    genSetRandDARTNumber();
    //]]></script><script type="text/javascript">
    // Get Cookie Value
    function getPartnerCookieValue (cookieName) {
       var exp = new RegExp (escape(cookieName) + "=([^;]+)");
       if(exp.test (document.cookie + ";")) {
          exp.exec (document.cookie + ";");
          return unescape(RegExp.$1);
       }
    }
    // Write Cookie
    function writePartnerCookie (CookieName, CookieValue, periodType, offset) {
       var expireDate = new Date ();
       offset = offset / 1;
       var myPeriodType = periodType;
       switch (myPeriodType.toLowerCase()) {
          case "years":
             var year = expireDate.getYear();
             // Note some browsers give only the years since 1900, and some since 0.
             if (year < 1000) year = year + 1900;
             expireDate.setYear(year + offset);
          break;
          case "months":
             expireDate.setMonth(expireDate.getMonth() + offset);
          break;
          case "days":
             expireDate.setDate(expireDate.getDate() + offset);
          break;
          case "hours":
             expireDate.setHours(expireDate.getHours() + offset);
          break;
          case "minutes":
             expireDate.setMinutes(expireDate.getMinutes() + offset);
          break;
          default:
             // alert ("Invalid periodType parameter for writePartnerCookie()");
          break;
       }
       try{
          document.cookie = escape(CookieName ) + "=" + escape(CookieValue) + "; expires=" + expireDate.toGMTString() + "; path=/";
                 }catch(e){
                 }
       try{
          document.cookie = "partnerSessionCookie=xfinity; path=/";
                 }catch(ee){
                 }
    }
    </script><script type="text/javascript">
        function checkPartnerCookie () {
          if(getPartnerCookieValue("partnerCookie")=="xfinity" && getPartnerCookieValue("partnerSessionCookie")=="xfinity"){
            document.write('<scr'+'ipt src="//secure.xfinity.com/shared/js-api/polaris_vendor_iframes.js?signin=false&profile=nbc&ft=true&id=xfinityNavBar&locale=en"></scr'+'ipt>');// new header (includes footer)
            $(document).ready(function(){
              $('body').addClass('xfinity');
            });
            xfinityOmniValue = "xfinity";// referenced in nbc_tracking_revamped
          }
        }
       var xfinityOmniValue = "";
        checkPartnerCookie();
       </script><script src="//www.nbcphiladelphia.com/includes/nbc_global_rr.js?r=-696152606" type="text/javascript"></script><script type="text/javascript">
    var disableDownloadApp = false;
      </script><script type="text/javascript">
      (function() {
        var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
        po.src = 'https://apis.google.com/js/plusone.js';
        var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
      })();
    </script><script type="text/javascript">
      var nbcinfoTools = nbcinfoTools || new nbc.tools('nbcinfoTools');
      nbcinfoTools.iframeChatter();
    </script><link rel="stylesheet" href="//www.nbcphiladelphia.com/templates/jquery.fancybox-1.3.4.css?r=954862844" type="text/css" /><meta name="taboola_lead" content="video"><script type="text/javascript">
        window._taboola = window._taboola || [];
                  _taboola.push({article:'494735391', tracking:'_osource=taboola-recirc'});
                !function (e, f, u) {
          e.async = 1;
          e.src = u;
          f.parentNode.insertBefore(e, f);
        }(document.createElement('script'),
        document.getElementsByTagName('script')[0],
        '//cdn.taboola.com/libtrc/nbcots-network/loader.js');
      </script><script>
      window._newsroom = window._newsroom || [];
            !function (e, f, u) {
        e.async = 1;
        e.src = u;
        f.parentNode.insertBefore(e, f);
      }(document.createElement('script'),
      document.getElementsByTagName('script')[0], '//c2.taboola.com/nr/nbcots-wcau/newsroom.js');
    </script><script src="//native.sharethrough.com/assets/sfp.js"></script><script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script><script>Sailthru.init({ customerId: '757cc89c051f4552fa5708e6f3b93a01' });</script><script async src="//js-sec.indexww.com/ht/p/186439-186231565045987.js"></script></head><body id="article" class="article-phi  phi news   nbc "><div id="adTransitionalContainer"></div><script type="text/javascript">
    //must have for commenting
    var nbcfacebook = {
      connected: "no"
    };
  </script><script>
      function callTransitional() {
        window.location.href = nbc.fullDomain + '/transitional_ad/transitional_ad.html';
      }
    </script><div class="site-header-wrapper"><div class="site-header"><div class="breaking-bar" data-tb-region="breaking-news"><div class="breaking-wrapper"><div class="breaking-header"><a href="https://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Pennsylvania-Injuries-Fire-494715991.html"  name="&lpos=At Least 1 Dead in 'Intentional' Car Explo...&lid=Breaking News Bar" data-lpos="At Least 1 Dead in 'Intentional' Car Explo..." data-lid="Breaking News Bar">DEVELOPING:&nbsp;</a></div><div class="breaking-content" data-tb-region-item><div class="breaking-title"><a href="https://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Pennsylvania-Injuries-Fire-494715991.html"  name="&lpos=At Least 1 Dead in 'Intentional' Car Explo...&lid=Breaking News Bar" data-lpos="At Least 1 Dead in 'Intentional' Car Explo..." data-lid="Breaking News Bar">At Least 1 Dead in 'Intentional' Car Explo...</a></div></div></div></div><!-- navbarClass: nav-landing --><div class="navbar nav-landing"><div class="navbar-container"><div class="row"><div class="col--2"><div class="brand"><a target="_parent" href="/" name="&lpos=section navigation&lid=logo" data-lpos="section navigation" data-lid="logo"><img src="//media.nbcmiami.com/designimages/logo_philly_2x.png" alt="logo_philly_2x" /></a></div></div><div class="col--14"><ul class="nav-sections"><li class="nav-section Home"><a target="_parent" class="nav-section-title " href="/" alt="Home" lid=Home" data-lid="Home">Home</a></li><li class="nav-section News"><a target="_parent" class="nav-section-title nav-selected" href="/news" alt="News" lid=News" data-lid="News">News</a><div class="subnav-large-container"><div class="subnav-section-landing"><ul><li><a target="_parent" href="/news/local/" alt="Local"  data-lpos="subsection navigation" data-lid="Local">Local</a></li><li><a target="_parent" href="https://www.nbcphiladelphia.com/news/politics/Decision-2018-November-Midterm-Elections-490470381.html" alt="Politics"  data-lpos="subsection navigation" data-lid="Politics">Politics</a></li><li><a target="_parent" href="/news/national-international/" alt="U.S. & World"  data-lpos="subsection navigation" data-lid="U.S. & World">U.S. & World</a></li><li><a target="_parent" href="/news/sports/" alt="Sports"  data-lpos="subsection navigation" data-lid="Sports">Sports</a></li><li><a target="_parent" href="/news/sports/Philadelphia-Phillies-453010213.html" alt="Phillies"  data-lpos="subsection navigation" data-lid="Phillies">Phillies</a></li><li><a target="_parent" href="/news/sports/Philadelphia-Eagles-443033743.html" alt="Eagles"  data-lpos="subsection navigation" data-lid="Eagles">Eagles</a></li><li><a target="_parent" href="/news/sports/Philadelphia-76ers-453012353.html" alt="Sixers"  data-lpos="subsection navigation" data-lid="Sixers">Sixers</a></li><li><a target="_parent" href="/news/health" alt="Health"  data-lpos="subsection navigation" data-lid="Health">Health</a></li><li><a target="_parent" href="https://www.nbcphiladelphia.com/news/local/PHI-Wednesdays-Child-236075691.html?page=1" alt="Wednesday's Child"  data-lpos="subsection navigation" data-lid="Wednesday's Child">Wednesday's Child</a></li><li><a target="_parent" href="/news/weird/" alt="Weird"  data-lpos="subsection navigation" data-lid="Weird">Weird</a></li><li><a target="_parent" href="http://www.nbcphiladelphia.com/news/business/NBC10GrowingGreaterPhiladelphia-417042043.html" alt="Growing Greater Philadelphia"  data-lpos="subsection navigation" data-lid="Growing Greater Philadelphia">Growing Greater Philadelphia</a></li></ul></div></div></li><li class="nav-section Weather"><a target="_parent" class="nav-section-title " href="/weather" alt="Weather" lid=Weather" data-lid="Weather">Weather</a><div class="nav-section-subnav"><ul><li><a target="_parent" href="/weather/" alt="Forecast"data-lpos="subsection hover" data-lid="Forecast">Forecast</a></li><li><a target="_blank" href="http://www.nbcphiladelphia.com/weather/stories/PHI-Severe-Weather-Central-224616871.html" alt="Severe Weather Central"data-lpos="subsection hover" data-lid="Severe Weather Central">Severe Weather Central</a></li><li><a target="_parent" href="/weather/school-closings" alt="School Closing Alerts"data-lpos="subsection hover" data-lid="School Closing Alerts">School Closing Alerts</a></li><li><a target="_parent" href="/weather/maps/" alt="Maps & Radar"data-lpos="subsection hover" data-lid="Maps & Radar">Maps & Radar</a></li><li><a target="_parent" href="/weather/stories/" alt="Weather Stories"data-lpos="subsection hover" data-lid="Weather Stories">Weather Stories</a></li><li><a target="_parent" href="/weather/severe-weather-alerts" alt="Weather Alerts"data-lpos="subsection hover" data-lid="Weather Alerts">Weather Alerts</a></li></ul></div></li><li class="nav-section Politics"><a target="_parent" class="nav-section-title " href="/news/politics/Decision-2018-November-Midterm-Elections-490470381.html" alt="Politics" lid=Politics" data-lid="Politics">Politics</a></li><li class="nav-section Investigators"><a target="_parent" class="nav-section-title " href="/investigations" alt="Investigators" lid=Investigators" data-lid="Investigators">Investigators</a><div class="nav-section-subnav"><ul><li><a target="_parent" href="http://www.nbcphiladelphia.com/investigations" alt="NBC10 Investigators"data-lpos="subsection hover" data-lid="NBC10 Investigators">NBC10 Investigators</a></li><li><a target="_parent" href="http://www.nbcphiladelphia.com/investigations/NBC10-Responds-376402961.html" alt="NBC10 Responds"data-lpos="subsection hover" data-lid="NBC10 Responds">NBC10 Responds</a></li><li><a target="_parent" href="http://www.nbcphiladelphia.com/consumer-form/" alt="How to Submit to NBC10 Responds"data-lpos="subsection hover" data-lid="How to Submit to NBC10 Responds">How to Submit to NBC10 Responds</a></li></ul></div></li><li class="nav-section nav-more"><a target="_parent" class="nav-section-title" href="" name="&lpos=ellipsis hover&lid=ellipsis" data-lpos="ellipsis hover" data-lid="ellipsis"><div class="more-dropdown"></div></a><div class="nav-section-subnav"><ul><li><a target="_parent" href="/entertainment" alt="Entertainment" name="&lpos=ellipsis hover&lid=Entertainment" data-lpos="ellipsis hover" data-lid="Entertainment">Entertainment</a></li><li><a target="_parent" href="/traffic" alt="Traffic" name="&lpos=ellipsis hover&lid=Traffic" data-lpos="ellipsis hover" data-lid="Traffic">Traffic</a></li><li><a target="_parent" href="/on-air/contests/" alt="Contests" name="&lpos=ellipsis hover&lid=Contests" data-lpos="ellipsis hover" data-lid="Contests">Contests</a></li><li><a target="_parent" href="/contact-us/" alt="Contact Us" name="&lpos=ellipsis hover&lid=Contact Us" data-lpos="ellipsis hover" data-lid="Contact Us">Contact Us</a></li><li><a target="_parent" href="https://sjobs.brassring.com/tgwebhost/searchresults.aspx?PartnerId=25354&SiteId=5108&Function=LinkQuery&LinkId=3385146" alt="Jobs at NBC10" name="&lpos=ellipsis hover&lid=Jobs at NBC10" data-lpos="ellipsis hover" data-lid="Jobs at NBC10">Jobs at NBC10</a></li><li><a target="_parent" href="http://www.nbcphiladelphia.com/contact-us/tv-listings" alt="TV Listings" name="&lpos=ellipsis hover&lid=TV Listings" data-lpos="ellipsis hover" data-lid="TV Listings">TV Listings</a></li></ul></div></li></ul></div><div class="col--8"><ul class="nav-small"><li class="nav-small-section nav-live-tv"><a target="_parent" href="/live" alt="Watch Live TV" class="nav-small-item" name="&lpos=Navigation - Watch Live TV&lid=Watch Live TV" data-lpos="Navigation - Watch Live TV" data-lid="Watch Live TV"><div class="watch-live-logo"></div></a><ul class="nav-small-sub"><li class="livetv">LIVE TV</li><li class="onnow">ON NOW</li><li><a target="_blank" href="/live" alt="NASCAR Racing" name="&lpos=Navigation - Watch Live TV&lid=NASCAR Racing" data-lpos="Navigation - Watch Live TV" data-lid="NASCAR Racing"><div class="watch-live-key"></div><div class="watch-live-title">NASCAR Racing</div><div class="play-grey-small"></div></a></li><li class="ondemand">ON DEMAND</li><li><a target="_blank" href="https://www.nbc.com/video" alt="NBC on Demand" name="&lpos=Navigation - Watch Live TV&lid=NBC on Demand" data-lpos="Navigation - Watch Live TV" data-lid="NBC on Demand"><div class="watch-live-key"></div><div class="watch-live-title">NBC on Demand</div><span class="desc">Watch the latest full episodes of your favorite NBC series anytime and anywhere.</span><div class="play-grey-small arrow"></div></a></li><li class="schedule"><a href="/contact-us/tv-listings/" alt="NBC on Demand" name="&lpos=Navigation - Watch Live TV&lid=Click for full schedule" data-lpos="Navigation - Watch Live TV" data-lid="Click for full schedule">Click for full schedule</a></li></ul></li><li><div class="nav-border"></div></li><li class="nav-small-section nav-weather"><a target="_parent" href="/weather" alt="weather" class="nav-small-item" name="&lpos=section navigation&lid=weather bug" data-lpos="section navigation" data-lid="weather bug"><div class="nav-weather-condition"><div class="nav-weather-icon"><img src="//media.nbcphiladelphia.com/designimages/ots_light_wx_66.png" alt="Scattered Clouds" /></div><div class="nav-weather-temp">72&deg;</div></div></a></li><li><div class="nav-border"></div></li><li class="nav-small-section nav-connect"><a target="_parent" href="" class="nav-small-item"><div>Connect</div></a><div class="subnav-large-container"><div class="nav-connect-sub"><div class="connect-media"><div class="connect-social"><div class="connect-social-icons"><a target="_parent" href="https://twitter.com/nbcphiladelphia" alt="Twitter" target="_blank" name="&lpos=Navigation - Connect&lid=Twitter" data-lpos="Navigation - Connect" data-lid="Twitter"><i class="fa fa-twitter"></i></a></div><div class="connect-social-icons"><a target="_parent" href="https://www.facebook.com/nbcphiladelphia" alt="Facebook" target="_blank" name="&lpos=Navigation - Connect&lid=Facebook" data-lpos="Navigation - Connect" data-lid="Facebook"><i class="fa fa fa-facebook-official" aria-hidden="true"></i></a></div><div class="connect-subnav-title">Social Media</div></div><div class="connect-apps"><a target="_parent" href="/mobile" alt="mobile" name="&lpos=Navigation - Connect&lid=Mobile" data-lpos="Navigation - Connect" data-lid="Mobile"><div class="connect-apps-icon"><div class="connect-mobile"></div></div><div class="connect-subnav-title">Our Apps</div></a></div><div class="connect-email"><a target="_parent" href="/newsletters" alt="newsletters" name="&lpos=Navigation - Connect&lid=Newsletters" data-lpos="Navigation - Connect" data-lid="Newsletters"><div class="connect-email-icon"><div class="connect-newsletter"></div></div><div class="connect-subnav-title">Newsletters</div></a></div><div class="connect-ugc"><a target="_parent" href="/ugc" alt="ugc" name="&lpos=Navigation - Connect&lid=UGC" data-lpos="Navigation - Connect" data-lid="UGC"><div class="connect-ugc-icon"><i class="fa fa-camera"></i></div><div class="connect-subnav-title">
                                                  See It, Share It
                                              </div></a></div><div class="connect-send"><a target="_blank" href="mailto:tips@nbcphiladelphia.com?body=Thanks%20for%20contacting%20NBC 10 Philadelphia.%20Please%20use%20this%20e-mail%20to%20send%20us%20news%20tips.%20Be%20sure%20to%20include%20a%20phone%20number,%20so%20we%20can%20contact%20you%20quickly,%20if%20necessary.%20If%20your%20tip%20is%20urgent,%20call%20%20our%20news%20desk%20at%20610-668-5510." alt="submit tips" name="&lpos=Navigation - Connect&lid=Submit Tips" data-lpos="Navigation - Connect" data-lid="Submit Tips"><div class="connect-apps-icon"><div class="connect-tips"></div></div><div class="connect-subnav-title">Send Tips</div></a></div></div><div class="connect-responds"><a target="_parent" href="/consumer-form" name="&lpos=Navigation - Connect&lid=consumer-form" data-lpos="Navigation - Connect" data-lid="consumer-form"><div class="connect-subnav-title"><img src="//media.nbcmiami.com/designimages/NBC_OTS_CONSUMER_PHILLY.png" alt="NBC_OTS_CONSUMER_PHILLY"></div><div class="connect-subnav-title">
                        Submit a Complaint
                      </div></a></div></div><div class="nav-connect-footer"><ul><li class="submit-tips"><a target="_parent" href="mailto:tips@nbcphiladelphia.com?body=Thanks%20for%20contacting%20NBC 10 Philadelphia.%20Please%20use%20this%20e-mail%20to%20send%20us%20news%20tips.%20Be%20sure%20to%20include%20a%20phone%20number,%20so%20we%20can%20contact%20you%20quickly,%20if%20necessary.%20If%20your%20tip%20is%20urgent,%20call%20%20our%20news%20desk%20at%20610-668-5510." alt="submit tips" name="&lpos=Navigation - Connect&lid=Submit Tips" data-lpos="Navigation - Connect" data-lid="Submit Tips">Submit Tips</a></li><li class="send-feedback"><a target="_parent" href="/send-feedback" alt="send feedback" name="&lpos=Navigation - Connect&lid=Send Feedback" data-lpos="Navigation - Connect" data-lid="Send Feedback">Send Feedback</a></li><li class="terms"><a target="_parent" href="/terms" alt="terms" name="&lpos=Navigation - Connect&lid=Terms of Service" data-lpos="Navigation - Connect" data-lid="Terms of Service">Terms of Service</a></li><li class="privacy-policy"><a target="_parent" href="https://www.nbcuniversal.com/privacy" alt="privacy policy" target="_blank" name="&lpos=Navigation - Connect&lid=Privacy Policy" data-lpos="Navigation - Connect" data-lid="Privacy Policy">Privacy Policy</a></li><li class="partner"><div class="partner-text">Visit our partner site</div><div class="connect-brand"><a target="_parent" href="http://www.telemundo62.com" alt="Duopoly" target="_blank" name="&lpos=Navigation - Connect&lid=Duopoly" data-lpos="Navigation - Connect" data-lid="Duopoly"><img src="//media.nbcmiami.com/designimages/WWSI.png" alt="WWSI"></a></div></li></ul></div></div></li><li><div class="nav-border"></div></li><li class="nav-small-section nav-search"><div class="nav-small-item"><div class="search-logo"></div><div class="search-logo-close"></div></div><div class="search-container"><form action="https://www.nbcphiladelphia.com/results/" method="get" target="_parent" id="nav-search"><div class="search-field"><input type="text" placeholder="Search" name="keywords" autocomplete="off" /><div class="search-field-logo"></div></div></form></div></li></ul></div></div></div></div></div></div><!-- End header --><div id="adBackgroundContainer"></div><div class="adcontainer"><div class="ad-container "><div id="leaderboard1" class="adSlot adLeaderboard" data-sizes="970,66|970,90|728,90" data-ord="1" data-pos="top" data-module="" data-gptcollapse="true"><script class="insertAdMPS">
	var SLOT='topbanner'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
	</script></div><div class="ad-container-close"><img src="//media.nbcmiami.com/designimages/ots-double-arrow.png" /></div></div></div><script language="javascript1.2">var trkcid=494735391;var partnerID=525842; var _hb=1;</script><script language="javascript1.2" src="https://www.nbcphiladelphia.com/g/g/button/button_1.js"></script><body id="article_0"><section id="article-sec_0"><!--[if lte IE 8 ]><div class="article_section"><![endif]--><div id="article_0" class="article_elements  medium   "><style>
#tve_cta {
  position: fixed;
  min-width: 330px;
  bottom: 0px;
  background: rgba(24,69,170,0.90);
  z-index: 1000;
  display:none;
  width: auto;
}
.tlmd #tve_cta {
    background: rgba(5,32,69,0.90);
}
#tve_cta.footerStop {
    position: absolute;
    bottom: -75px;
}
.tlmd #tve_cta.footerStop {
    bottom: 0px;
}
#tve_cta span.close_cta {
  position: absolute;
  width: 10px;
  height: 10px;
  background: url('//media.nbcnewyork.com/images/tve_close_icon.png') no-repeat;
  right: 5px;
  top: 5px;
  cursor:pointer
}

#tve_cta .tve_cta_container {
  overflow: hidden;
  padding:22px 24px 0 14px;
  height:44px;
}
.nbc #tve_cta .tve_cta_container {
  background: url('//media.nbcnewyork.com/images/tve_cta_bg.png') no-repeat;
}

#tve_cta .tve_cta_container .play {
  float: left;
}
.tlmd #tve_cta .tve_cta_container .play {
    display: inline-block;
    width: 100px;
    margin-top: -8px;
}

#tve_cta .tve_onNow {
  float: left;
  font-family: Roboto;
  font-size: 16px;
  color: #fff;
  margin: 2px 37px 0 10px;
}

#tve_cta .tve_show_onnow {
  float: left;
  overflow: hidden;
  margin:-10px 0 0;
}

#tve_cta h2 {
  font-family: Roboto;
  font-size: 16px;
  color: #fff;
  font-weight: 300;
  margin: 0;
}
#tve_cta h2 .tlmdHeader {
    color: #ECAF45;
    font-weight: 500;
    padding-right: 10px;
}
#tve_cta h3#tve_cta_showDek{
    font-size: 12px;
    color: #fff;
    margin-top: 5px;
}
/* Mobile Only */
.page-container h3#tve_cta_showDek {
    display: none;
}
.page-container #tve_cta {
    width: 100%;
    min-width:0px;
}
.page-container #tve_cta span.close_cta {
    width: 18px;
    height: 18px;
    background: url(//media.nbcnewyork.com/designimages/close_btn_2x.png) no-repeat;
    background-size: 18px 18px;
    top: -7px;
}
.tlmd .page-container #tve_cta span.close_cta {
    background: url(//media.nbcnewyork.com/designimages/tlmd_close_btn_2x.png) no-repeat;
    background-size: 18px 18px;
}
.page-container #tve_cta h2 {
    margin-top: 11px;
    max-width: 200px;
}
.page-container #tve_cta .tve_cta_container {
    padding-right:0px;
}
</style><div id="tve_cta"><div class="tve_cta_container"><a href="/live"><span class="play"><img src="//media.nbcmiami.com/images/tve-play-icon.png" /></span><div class="tve_onNow">WATCH LIVE</div><div class="tve_show_onnow"><h2><span id="tve_cta_showTitle">NASCAR Racing</span></h2><h3 id="tve_cta_showDek">The Bank of America 500 marks the final race of the Monster Energy NASCAR Cup Series' Round of 16.</h3></div></a></div><span class="close_cta"></span></div><!--startclickprintinclude--><article id="article_0_elements"><div id="article_0_headline_byline" class="headline_region"><h1 class="headline" itemprop="headline">Allentown Car Explosion Prompts Street Closures, Detours</h1><h2 class="subtitle"></h2><h3 class="byline"> By
                                                                                       <a href="/results/?keywords=%22NBC10+Staff%22&byline=y&sort=date">NBC10 Staff</a></h3><h3 class="dateline" style="font-family: Roboto;font-size: 0.8em;color: #969696;margin: 10px 0;font-weight: 300;padding-left: 5px;">Published 59 minutes ago</h3><!--endclickprintinclude--><script type="application/ld+json">

              {
                "@context": "http://schema.org",
                "@type": "NewsArticle",
                "mainEntityOfPage": "https://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Prompts-Street-Closures-Detours-494735391.html",
                "headline": "Allentown Car Explosion Prompts Street Closures, Detours",
                "datePublished": "Sun, 30 Sep 2018 13:45:45 -0400",
                "dateModified": "Sun, 30 Sep 2018 14:13:12 -0400",
                "description": "Federal, state and local law enforcement agencies descended on the immediate area of West Turner Street near North Hall Street, prompting street closures and public transportation detours.",
                "speakable": {
                  "@type": "SpeakableSpecification",
                  "cssSelector": [".headline", ".subtitle"]
                },
                                  "author": {
                    "@type": "Person",
                    "name": "NBC10 Staff "
                  },
                                "publisher": {
                  "@type": "Organization",
                  "name": "NBC 10 Philadelphia",
                  "logo": {
                    "@type": "ImageObject",
                    "url": "https://media.nbcphiladelphia.com/designimages/light-bg-phi-logo_2x.png",
                    "height": 60,
                    "width": 600
                  }
                },
                                  "image": {
                    "@type": "ImageObject",
                    "url": "https://media.nbcphiladelphia.com/images/652*367/Car_Explosion_in_Allentown.jpg",
                    "height": 546,
                    "width": 970
                  }
                              }
            </script><div class="socialNetworks-top"><div class="social-icon facebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Prompts-Street-Closures-Detours-494735391.html" onclick="window.open(this.href, 'facebookWindow',
            'width=500,height=500'); return false;" title="Facebook"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-facebook fa-stack-1x fa-inverse"></i></span></i></a></div><div class="social-icon twitter"><a href="https://twitter.com/share?url=https://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Prompts-Street-Closures-Detours-494735391.html&text=Allentown Car Explosion Prompts Street Closures, Detours&via=nbcphiladelphia" onclick="window.open(this.href, 'twitterWindow', 'width=500,height=500'); return false;" title="Twitter"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-twitter fa-stack-1x fa-inverse"></i></span></a></div><div class="social-icon comment"><a href="#comments" title="Comment"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-comments-o fa-stack-1x fa-inverse"></i></span></a></div><div class="social-icon email" onmouseout="return(ETMouseOut());" onmouseover="return(ETMouseOver());" onclick="nbc.updatePrintCall(this);return(ET());" title="Email"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-envelope-o fa-stack-1x fa-inverse"></i></span></div><div class="social-icon print" onmouseout="return(PTMouseOut());" onmouseover="return(PTMouseOver());" onclick="nbc.updatePrintCall(this);return(PT());" title="Print"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-print fa-stack-1x fa-inverse"></i></span></div></div></div><div class="article rightrail"><div class="rail adunit rect1" data-size="300x250" style="position:relative;"><span id="tp-ad-slot_300x250" class="_fwph freewheelRightRail"><form id="_fw_form_tp-ad-slot_300x250" style="display:none"><input type="hidden" name="_fw_input_tp-ad-slot_300x250" id="_fw_input_tp-ad-slot_300x250" value="w=300&h=250&envp=g_js"></form><span id="_fw_container_tp-ad-slot_300x250" class="_fwac"></span></span><div id="rect1" class="adSlot adRect" data-sizes="50,50|300,250|300,600" data-ord="1" data-pos="top" data-module="" data-gptcollapse="false" style="width: auto; height: auto;"><script class="insertAdMPS">
	var SLOT='topbox'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
	</script></div></div><div class="rail topstories"><h3 id="storyListHeader-0" class="rightrail title"></h3><div class="blackdivider1"></div><ul id="storyList-0"></ul></div><div class="rail weatherbug" style="margin: 25px 0;"><div class="rail weatherbug"><div id="top-stories-weather"><div class="weather-module"><div id="weather-module-data-0"><div id="processingWeatherLoading"><img alt="processing..." src="//media.nbcmiami.com/designimages/nbc-ajax-loader.gif"/></div></div></div></div></div></div><script type="text/javascript" src="https://www.civicscience.com/widget/jspoll/?elt=civsci-1861572874&tgtid=67ed2dfc-f223-44f4-f9e9-6ebcf5490750"></script><div id="civsci-1861572874" class="module-civicScience"></div><div class="rail adunit rect2" data-size="300x160"><div id="rectSmall1" class="adSlot adRectSmall" data-sizes="300,160" data-ord="1" data-pos="top" data-module=""><script class="insertAdMPS">
	var SLOT='bottomrectangle'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
	</script></div></div><!-- loadInlineNwsModule | $loadInlineNwsModule --><!-- nwsLetterEmbedded  | $nwsLetterEmbedded --><!-- nwsModuleAttached | false --><style type="text/css">
        .newsletterSignupBox .nsForm {position:relative;}
        #nsAjaxLoader {position:absolute;top:0;left:0;background:url("//media.nbcphiladelphia.com/designimages/nsuLoader.gif") 18px 6px no-repeat #ffffff;width:270px;height:26px;z-index:1;}
        input.nsSubscribe:focus {outline:none;}
        </style><div class="newsletterSignupBox"><div class="nsBox"><h3 class="rightrail title"><a href="/newsletters"> NEWSLETTERS </a></h3><a href="/newsletters"></a><div class="blackdivider1"></div><h3 class="newsletter copy">Receive the latest local  updates in your inbox</h3><form method="post" id="newsletterBox-0" class="nsForm" name="ns-subscribe-form" class="validate" target="_blank" data-nsHandlerKey = "WCAU_NewsNoon"  data-nsTmpID = "8"><span id="nsAjaxLoader" style="display:none"></span><fieldset><label class="form-float"><input class="required nsEmail form-input" name="EMAIL" type="text" placeholder="Email" onfocus="nsu.clearSignup(this)" /><span class="form-float-label">Email</span></label><input class="nsSubscribe form-btn" name="subscribe" type="submit" value="Sign up" /></fieldset></form></div><div class="nsFooter"><a href="http://www.nbcuniversal.com/privacy/" name="&lpos=Newsletter Sign Up&lid=Privacy policy" data-lpos="Newsletter Sign Up" data-lid="Privacy policy">Privacy policy</a> | <a href="/newsletters/" name="&lpos=Newsletter Sign Up&lid=More Newsletters" data-lpos="Newsletter Sign Up" data-lid="More Newsletters">More Newsletters</a></div></div><div class="rail adunit rect1" data-size="300x250"><div id="rect2" class="adSlot adRect" data-sizes="300,250" data-ord="2" data-pos="bottom" data-module="" data-gptcollapse="false" style="width: auto; height: auto;"><script class="insertAdMPS">
	var SLOT='bottombox'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
	</script></div></div></div><figure><div class="leadMediaRegion video"><div id="nextUp0" class="nextUpCard" style="display:none;"><span class="upNextTitle"> UP NEXT </span><img width="84" height="50"><div class="upNextSlate"></div><span class="openTab"></span><span class="closeButton">X</span></div><div id="endcard" style="display:none;"><div id="backplate"></div><div id="topRegion"><div id="backplateTop"></div><div class="items"><p class="videoTitle">Car Explosion in Allentown</p><ul id="socialTools"><li id="endcardShareBtns"></li></ul><ul id="additionalShare"><li class="shareLink"><span>Link</span></li><li class="shareEmbed"><span>Embed</span></li></ul></div></div><div class="shareBoxes"><div class="linkBox" style="visibility:hidden;"><div class="boxCopy boxBtn"><span>Copy</span></div><div class="boxClose boxBtn"><span>Close</span></div><p class="boxLabel"> Link to this video </p><form action="#"><fieldset><textarea rows="1" cols="2" readonly="readonly">//www.nbcphiladelphia.com/news/local/Car-Explosion-in-Allentown_Philadelphia-494717821.html</textarea></fieldset></form></div><div class="embedBox" style="visibility:hidden;"><div class="boxCopy boxBtn"><span>Copy</span></div><div class="boxClose boxBtn"><span>Close</span></div><p class="boxLabel"> Embed this video </p><form action="#"><fieldset><textarea rows="1" cols="2" readonly="readonly"><script type="text/javascript" charset="UTF-8" src="http://www.nbcphiladelphia.com/portableplayer/?cmsID=494717821&videoID=kFWtQERdwzao&origin=nbcphiladelphia.com&sec=news&subsec=local&width=600&height=360"></script></textarea></fieldset></form></div></div><p class="replayButton"><a href="#" onclick="return false;">Replay</a></p><div id="bottomRegion"><div id="backplateBottom"></div><div class="items"><p class="related"> More videos (1 of 9)</p><div class="relatedVideos"><ul class="videoBox"></ul></div><span class="pager prev">&laquo;</span><span class="pager next">&raquo;</span></div></div></div><div id="leadVideo0" class="leadMediaThumbnail video" data-ap="true" data-sponsor="" data-cid="494717821" data-vid="kFWtQERdwzao" data-title="Car Explosion in Allentown" data-thumb="https://media.nbcphiladelphia.com/images/144*81/Car_Explosion_in_Allentown.jpg"><div class="videoPlayButton medium"></div><h3 class="leadMediaTitle">Car Explosion in Allentown</h3><div class="videoOverlay"></div><img src="https://media.nbcphiladelphia.com/images/652*367/Car_Explosion_in_Allentown.jpg"></div></div><script>
            nbc.tbNextVideoIsSafe = false;
          </script><figcaption><!--startclickprintinclude--><div class="leadMediaCaption"><p>At least two people were injured in a car explosion in Allentown, Pennsylvania.</p> (Published Saturday, Sept. 29, 2018)</div><!--endclickprintinclude--></figcaption><div id="tbFilmStrip" style="width:622px;margin-left:16px;height:169px;background-color:#eee;overflow:hidden;position:relative;padding:16px;"><div class="placeholder-animation"><div class="first item"><div class="video gradient"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text last"></div></div><div class="second item"><div class="video gradient"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text last"></div></div><div class="third item"><div class="video gradient"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text last"></div></div><div class="fourth item"><div class="video gradient"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text last"></div></div></div><div id="tbFilmStripCarousel" style="overflow:hidden;"></div></div><script>
              nbc.tbNextVideoIsSafe = true;
                          </script></figure><!--startclickprintinclude--><div id="at_0" class="articleText" itemprop="articleBody"><p class="paragraph" data-pnum="1">At least one person was killed Saturday night in Allentown, Pennsylvania, after an <a target="_blank" href="https://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Pennsylvania-Injuries-Fire-494715991.html">"intentional" car explosion</a>, officials said.&nbsp;</p><p class="paragraph" data-pnum="2">Federal, state and local law enforcement agencies descended on the immediate area of&nbsp;West Turner Street near North Hall Street, prompting street closures and public transportation detours.</p><div class="embedded article"><ul class=""><li class="flag "><h3><span class=""></span><a href="//www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Pennsylvania-Injuries-Fire-494715991.html">At Least 1 Dead in 'Intentional' Car Explosion in Allentown </a></h3></li></ul></div><p class="paragraph" data-pnum="3">Commuters were asked Sunday morning to avoid the area from 7th to 8th streets and Linden to Chew streets. A shelter has been set up at Cleveland Elementary School at 424 9th Street for anyone displaced by the incident.</p><p class="paragraph" data-pnum="4">Due to the investigation and subsequent road closures, the following road sections will not have any LANtaBus service.</p><p class="paragraph" data-pnum="5"><b>Current Closures:</b></p><p class="paragraph" data-pnum="6">Turner Street between 9th Street and the Allentown Transportation Center</p><p class="paragraph" data-pnum="7">7th Street between Chew Street and Linden Street</p><p class="paragraph" data-pnum="8">Linden Street between 7th Street and 9th Street</p><p class="paragraph" data-pnum="9">8th Street between Linden Street and Chew Street</p><p class="paragraph" data-pnum="10">There is no bus or access to the Allentown Transportation Center</p><p class="paragraph" data-pnum="11">For buses that normally exit the ATC via 7th Street or via Church Street, buses are waiting on Linden Street. For buses that normally exit ATC via 6th Street, they are parking along the Morning Call Building and will continue normal routing from there.</p><div class="articleAutoFooter"><p>&nbsp;&nbsp;</p></div><h5 class="copyright"></h5><!--endclickprintinclude--><div id="taboola-below-article-thumbnails" style="margin-top:50px;"></div><script type="text/javascript">
                  /** scroll cookie for scroll.com **/
                  if (document.cookie.indexOf("scroll0=") < 0) {
                    window._taboola = window._taboola || [];
                    _taboola.push({
                       mode: 'thumbnails-a',                      container: 'taboola-below-article-thumbnails',
                       placement: 'Below Article Thumbnails',                      target_type: 'text'
                    });
                  };
                  </script><div id="taboola-below-article-text-links" style="clear:none"></div><script type="text/javascript">
                  /** scroll cookie for scroll.com **/
                  if (document.cookie.indexOf("scroll0=") < 0) {
                    window._taboola = window._taboola || [];
                    _taboola.push({
                       mode: 'hybrid-text-links-a',                        container: 'taboola-below-article-text-links',
                       placement: 'Below Article Text Links',                      target_type: 'text'
                    });
                  };
                  </script></div><!--startclickprintinclude--></article><!--endclickprintinclude--><aside><div id="article-comments" itemprop="comment"><a name="comments"><span id="article-comments-header"> Leave Comments </span></a><div class="fb-comments" data-href="https://www.nbcphiladelphia.com/news/local/Allentown-Car-Explosion-Prompts-Street-Closures-Detours-494735391.html" data-num-posts="6" data-width="650" style="clear:both;"></div></div><div class="ad" id="ad_3"><div id="leaderboard2" class="adSlot adLeaderboard" data-sizes="728,90" data-ord="2" data-pos="bottom" data-module="" data-gptcollapse="true"><script class="insertAdMPS">
	var SLOT='bottombanner'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
	</script></div></div></aside><!--[if lte IE 8 ]></div><![endif]--></section><div id="contentTrigger" class="clear"></div><div id="loader"></div><div id="cScrollIndicatorRect"><div class="cScrollIndicatorContainer"><span id="cScrollIndicator"></span></div></div><div id="upwardScrollFixedRect"><div class="upwardScrollContainer"><span id="upwardScrollArrow"></span></div></div></div><style>
  .embeddedMediaCaption.medium {overflow:hidden;}
  .embeddedMediaCaption.medium div {display:inline;margin-right:3px;}
  .morecontent span { display: none; }
  .morecontent .showMoreLink,.morecontent .morelink {color:#1259a6;cursor:pointer;display:inline;font-weight:700;margin:0 5px;}

</style><script>
$(document).ready(function() {
  var showCharCount = 350;
  var ellipsesText = "...";
  var showMoreText = "Read more";
  var showLessText = "Read less";
  $('.embeddedMediaCaption div').not(".noExt").each(function() {
    $(this).find("p").each(function(){
      var content = $(this).html();
      $(this).parent().append(content);
      $(this).remove();
    });
    var descMoreContent = $(this).html();
    if(descMoreContent.length > showCharCount) {
      var initialCopy = descMoreContent.substr(0, showCharCount);
      var hiddenCopy = descMoreContent.substr(showCharCount, descMoreContent.length - showCharCount);
      var showMoreOutput = initialCopy + '<span class="moreellipses">' + ellipsesText+ '&nbsp;</span><span class="morecontent"><span>' + hiddenCopy + '</span><p class="showMoreLink">' + showMoreText + '</p></span>';
      var publishLine = $(this).parent().find(".pub").html();
      $(this).html(showMoreOutput);
      $(this).append(publishLine);
      $(this).parent().find(".pub").remove()
    }

  });

  $(".showMoreLink").click(function(){
    if($(this).hasClass("less")) {
      $(this).removeClass("less");
      $(this).html(showMoreText);
    } else {
      $(this).addClass("less");
      $(this).html(showLessText);
    }
    $(this).parent().prev().toggle();
    $(this).prev().toggle();
  });


  var showChar = 350;
  var ellipsestext = "...";
  var moretext = "Read more";
  var lesstext = "Read less";

  $('.leadMediaCaption p').each(function() {
    var content = $(this).html();

    if(content.length > showChar) {
      var c = content.substr(0, showChar);
      var h = content.substr(showChar, content.length - showChar);
      var html = c + '<span class="moreellipses">' + ellipsestext+ '&nbsp;</span><span class="morecontent"><span>' + h + '</span>&nbsp;&nbsp;<a href="" class="morelink">' + moretext + '</a></span>';
      $(this).html(html);
    }

  });

  $(".morelink").click(function(){
    if($(this).hasClass("less")) {
      $(this).removeClass("less");
      $(this).html(moretext);
    } else {
      $(this).addClass("less");
      $(this).html(lesstext);
    }
    $(this).parent().prev().toggle();
    $(this).prev().toggle();
    return false;
  });

});
</script><script src="//www.nbcphiladelphia.com/includes/article_desktop_require.js?r=-2102016363" type="text/javascript"></script><script language="Javascript" >var js="0.0";</script><script language="Javascript1.0" >js="1.0";</script><script language="Javascript1.1">js="1.1";</script><script language="Javascript1.2" >js="1.2";</script><script language="Javascript1.3">js="1.3";</script><script language="Javascript1.4" >js="1.4";</script><script language="Javascript1.5">js="1.5";</script><script language="Javascript1.6">js="1.6";</script><script language="Javascript1.7">js="1.7";</script><script language="Javascript1.8">js="1.8";</script><script language="Javascript1.9">js="1.9";</script><script language="javascript1.1" type="text/javascript"><!-- 
var bb=new Image();var _ti=910;var _q="";var na=(navigator.appName=="Netscape");var ns=(navigator.appName.substring(0,9)=="Microsoft");var _qDate=new Date();var _r=(document.referrer.indexOf(getdomain(location))>-1?"":document.referrer);_q+="&5="+parseInt(_qDate.getTimezoneOffset());_q+="&35="+parseInt(_qDate.toString().indexOf("aylight")>-1?1:0);_q+="&6=494735391";_q+="&7=525842";_q+="&8="+encodeURIComponent(document.location);_q+="&9="+encodeURIComponent(_r);_q+="&10="+encodeURIComponent(document.title);_q+="&11="+encodeURIComponent(navigator.userAgent);_q+="&12="+encodeURIComponent((na?navigator.language:navigator.userLanguage));_q+="&13="+((navigator.javaEnabled()?'1':'0'));_q+="&14="+encodeURIComponent(js);if(document.cookie.indexOf("cc")==-1)document.cookie="cc=t;";_q+="&15="+((document.cookie.indexOf("cc")==-1)?"0":"1");_q+="&16="+encodeURIComponent((screen.width+'x'+screen.height));_q+="&17="+encodeURIComponent(((ns)?screen.colorDepth:screen.pixelDepth));_q+="&18="+encodeURIComponent(Math.random());_q+="&19="+_ti;bb.src="https://s.clickability.com/s?"+_q;
function getdomain(a){var i=a.host.indexOf(":");return (i>=0)?a.host.substring(0,i):a.host;}if(self['setupalready']){var dosetup = false;alert('There are two $imware.tracker calls on this page. Please alert Client Services');}else{var dosetup = true;var hasonload=false;}//--></script><noscript><img width="1" height="1" src="https://s.clickability.com/s?19=990&14=0&6=494735391&7=525842&25=0&18=0.4841087354340451"></noscript><script src="//www.nbcphiladelphia.com/includes/blockadblock.js?r=2042017172" type="text/javascript"></script><script language="JavaScript">

if (window.hasOwnProperty('nbcu') === false || !nbcu) {
  /* this is a fix for pages when ad blocker
     prevents AppMeasurement.js from loading.
  */
  var nbcu = {
    catchAll: function (attempted_function, args) {
      console.log('[NOAD_SUPPPORT] nbcu.' + attempted_function + ' ', args);
    },
    tl: function () {
      this.catchAll('tl', arguments);
    },
    t: function () {
      this.catchAll('t', arguments);
    }
  };
}

if (!nbc.showAdClips) {
  var removeAdClips = function (evtData) {
    console.log('removeAdClips', evtData);

    var newClips = [],
        regMatch = new RegExp('ads\\.freewheel'),
        clip = null;

    if (evtData.hasOwnProperty('data') && evtData.data.hasOwnProperty('clips')) {
      for ( i in evtData.data.clips ) {
        clip = evtData.data.clips[i];

        if ( regMatch.exec(clip.URL) ) {
          continue;
        }
        newClips.push(clip);
      }
    }

    if (newClips.length > 0) {
      evtData.data.clips = newClips;
    }
  };

  $pdk.controller.addEventListener('OnReleaseStart', 'removeAdClips', ['*']);
}

                  nbcu.pageName="local:detail content page";
            nbcu.pageType=""; // used for 404 Error message page only
nbcu_siteID="nbcphiladelphia";
nbcu.list1="sharethrough:weather:news newsletter sign up:article lead video player:taboola";
nbcu.prop8=nbcu_prop8; // division
nbcu.prop9=nbcu_prop9; // station market
nbcu.prop10=nbcu_prop10; // call letters
nbcu.prop21="494735391";// content id
        nbcu.prop22="Allentown Car Explosion Prompts Street Closures, Detours"; // content title
                nbcu.prop23="article video embed";
        nbcu.prop18="Alicia Lozano";
      
  var _cbq = window._cbq || [];
    _cbq.push(['_leadVideo', 'true']);
        nbcu.prop40="false";
  nbcu.prop24=""; // content group
nbcu.prop25="NBC10 Staff"; // author name
nbcu.prop26="09/30/2018";  nbcu.prop27="uncategorized"; //Content: feature step 2
        nbcu.prop28=""; //content source
nbcu.prop30 = "Philadelphia";
nbcu.eVar70 = "Sep 30, 2018";
  nbcu.prop48 = "desktop";
/* E-commerce Variables */
if(typeof nbc.articlePage.continuousScroll !== "undefined") {
  if(nbc.articlePage.continuousScroll) {
      nbcu.eVar56 = "batch 1";
        nbcu.eVar58 = "1";
      nbcu.eVar57 = 1;
      nbcu.events="event1,event2,event8,event18";; // filled with an event # as needed - example event1, or event19
  } else {
     nbcu.events="event2";
  }
} else {
    nbcu.events="event2";
}
nbcu.prop3="local";
nbcu.prop4="local";
nbcu.prop1="news";
nbcu.eVar1=nbcu.prop1;

// Xfinity Omniture Value
if(typeof xfinityOmniValue != "undefined") {
  if(xfinityOmniValue == "xfinity"){
    nbcu.prop29=xfinityOmniValue;
    nbcu.eVar29=xfinityOmniValue;
  } else{
    nbcu.prop29="";
    nbcu.eVar29="";
  }
}
var nbcSocialIcon = jQuery(".social-icon");
if(nbcSocialIcon.length > 0 && nbc.isMobile == "false") {
  var envTracking = "floating ";
  nbcSocialIcon.on('click touchstart', function (){
    nbcu.linkTrackVars="eVar7";
    nbcu.eVar7 = envTracking + "sharebar " + this.className.replace(/social-icon | /g,'');
    nbcu.tl(this,'o',nbcu.eVar7,null);
  })
};
var liveContext = jQuery(".live-context");
if(liveContext.length > 0) {
  nbcu.events = "event47";
}
blockAdBlock.on(true, function(){
    nbcu.linkTrackVars="eVar19";
  nbcu.eVar19 = "adblock true";
  nbcu.tl(this,'o',nbcu.eVar19,null);
});
if(typeof U == "object") {
  if(typeof U.sessionVideoPVTracker == "function") {U.sessionVideoPVTracker("pv");}
}
</script><script language="JavaScript">
/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
      var s_code=nbcu.t();if(s_code)document.write(s_code)//--></script><script language="JavaScript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'!-'+'-')</script><script type='text/javascript'>
if(document.location.protocol=='http:'){
var Tynt=Tynt||[];Tynt.push('bXPZ-CXVur458Cacwqm_6l');

(function(){var h,s=document.createElement('script');s.src='http://cdn.tynt.com/ti.js';
h=document.getElementsByTagName('script')[0];h.parentNode.insertBefore(s,h);})();}
</script><script type="text/javascript">
  //<![CDATA[
          var _sf_async_config={uid:15527,domain:"www.nbcphiladelphia.com"};
              _sf_async_config.path = "/news/local/Allentown-Car-Explosion-Prompts-Street-Closures-Detours-494735391.html";
                _sf_async_config.sections = "news,local";
                                      _sf_async_config.authors = "NBC10 Staff ";
              //]]></script><script type="text/javascript">
    //<![CDATA[
      (function(){
        function loadChartbeat() {
          window._sf_endpt=(new Date()).getTime();
          var e = document.createElement('script');
          e.setAttribute('language', 'javascript');
          e.setAttribute('type', 'text/javascript');
          e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
          document.body.appendChild(e);
          //for newsbeat

        }
        var oldonload = document.ready;
        document.ready = (typeof document.ready != 'function') ?
           loadChartbeat : function() { oldonload(); loadChartbeat(); };
      })();
    //]]></script><div id="fb-root"></div><script>
    var api_key = "85ab812aa7574de43da6e627c9970950";
    window.fbAsyncInit = function() {
      FB.init({
        appId      : 'api_key', // App ID
        version    : 'v2.6',
        channelUrl : '//www.nbcphiladelphia.com/templates/channel.html', // Channel File
        status     : true, // check login status
        cookie     : true, // enable cookies to allow the server to access the session
        xfbml      : true  // parse XFBML
      });
      // Additional initialization code here
    };
    // Load the SDK Asynchronously
    (function(d){
      var js, id = 'facebook-jssdk', ref = d.getElementsByTagName('script')[0];
      if (d.getElementById(id)) {return;}
      js = d.createElement('script'); js.id = id; js.async = true;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      ref.parentNode.insertBefore(js, ref);
    }(document));
  </script><script type="text/javascript" src="https://platform.twitter.com/widgets.js"></script><div class="footer"><div class="footer-container"><div class="row"><div class="col--8"><div class="footer-nav"><ul><li><a target="_parent" href="/news" alt="News" name="&lpos=footer&lid=News" data-lpos="footer" data-lid="News">News</a></li><li><a target="_parent" href="/weather" alt="Weather" name="&lpos=footer&lid=Weather" data-lpos="footer" data-lid="Weather">Weather</a></li><li><a target="_parent" href="/investigations/" alt="Investigations" name="&lpos=footer&lid=Investigations" data-lpos="footer" data-lid="Investigations">Investigations</a></li><li><a target="_parent" href="/entertainment" alt="Entertainment" name="&lpos=footer&lid=Entertainment" data-lpos="footer" data-lid="Entertainment">Entertainment</a></li><li><a target="_parent" href="/traffic" alt="Traffic" name="&lpos=footer&lid=Traffic" data-lpos="footer" data-lid="Traffic">Traffic</a></li><li><a target="_parent" href="/contact-us/" alt="Contact Us" name="&lpos=footer&lid=Contact Us" data-lpos="footer" data-lid="Contact Us">Contact Us</a></li><li><a target="_parent" href="/on-air/contests/" alt="Contests" name="&lpos=footer&lid=Contests" data-lpos="footer" data-lid="Contests">Contests</a></li></ul><div class="connect-social"><div class="connect-subnav-title">Connect With Us</div><div class="connect-social-icons"><a href="https://twitter.com/nbcphiladelphia" alt="Twitter" target="_blank" name="&lpos=Navigation - Connect&lid=Twitter" data-lpos="Navigation - Connect" data-lid="Twitter"><i class="fa fa-twitter"></i></a></div><div class="connect-social-icons"><a href="https://www.facebook.com/nbcphiladelphia" alt="Facebook" target="_blank" name="&lpos=Navigation - Connect&lid=Facebook" data-lpos="Navigation - Connect" data-lid="Facebook"><i class="fa fa-facebook-official" aria-hidden="true"></i></a></div></div></div></div><div class="col--8"><div class="footer-links"><ul><li><a target="_parent" href="http://corporate.comcast.com/news-information/nbcuniversal-transaction/independent-programming" alt="FCC Independent Programming Report">FCC Independent Programming Report</a></li><li><a target="_parent" href="http://corporate.comcast.com/news-information/nbcuniversal-transaction/news-and-information-programming" alt="FCC News and Information Programming Report">FCC News and Information Programming Report</a></li><li><a target="_parent" href="/non-profit-reports/NBC-Non-Profit-News-Partnership-Reports-138336674.html" alt="NBC Non-Profit News Partnership Reports">NBC Non-Profit News Partnership Reports</a></li><li><a target="_parent" href="https://publicfiles.fcc.gov/tv-profile/wcau" alt="WCAU Public Inspection File">WCAU Public Inspection File</a></li><li><a target="_parent" href="/employment" alt="Employment">Employment</a></li></ul><ul><li><a target="_parent" href="/send-feedback/" alt="feedback" name="&lpos=footer&lid=send feedback" data-lpos="footer" data-lid="send feedback">Send Feedback</a></li><li><a target="_parent" href="/terms/" alt="Terms of Service" name="&lpos=footer&lid=Terms of service" data-lpos="footer" data-lid="Terms of service">Terms of service</a></li><li><a target="_parent" href="http://www.nbcuniversal.com/privacy/" alt="privacy" name="&lpos=footer&lid=Privacy policy" data-lpos="footer" data-lid="Privacy policy">Privacy policy</a></li></ul></div></div><div class="col--8"><div class="footer-logo"><a target="_parent" href="" alt="logo" class="footer-nbcu" name="&lpos=footer&lid=nbc universal logo" data-lpos="footer" data-lid="nbc universal logo"></a></div><div class="footer-copyright footer-logo">
                      © 2018 NBCUniversal Media, LLC. All rights reserved.
          </div><div class="footer-copyright"><a id="_bapw-link" href="#" alt="AdChoices" class="leftTerms" target="_blank" style="cursor: pointer;color:#fff;"><img id="_bapw-icon" style="vertical-align: middle;padding-right: 5px;"/><span style="vertical-align: middle;">AdChoices</span></a><script type="text/javascript">
            (function() {
              var ev = document.createElement('script'); ev.type = 'text/javascript'; ev.async = true; ev.setAttribute('data-ev-tag-pid', 209); ev.setAttribute('data-ev-tag-ocid', 908);
              ev.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'c.betrad.com/pub/tag.js';
              var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ev, s);
            })();
            </script></div></div></div></div></div><!-- Begin comScore Tag --><script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035083" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script><noscript><img src="http://b.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" /></noscript><!-- End comScore Tag --><style type="text/css">
        #home .stack-wrapper .adMicro .mps-slot {width:100%!important;} #home .stack-wrapper .adMicro .mps-slot &gt; div &gt; iframe {height:40px!important;} #home .stack-sponsorship iframe {height:50px!important;}#globalRightRail .sponsorshipCat iframe{height:50px;}
      </style><script>mps.writeFooter && mps.writeFooter();</script></body></html>
