<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		
	<link rel="profile" href="https://gmpg.org/xfn/11">
	<title>Angry Dawgs: No. 3 Georgia Beats No. 2 Michigan 34-11 in Orange Bowl &#8211; NBC10 Philadelphia</title>
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//z.moatads.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC10 Philadelphia &raquo; Feed" href="https://www.nbcphiladelphia.com/?rss=y" />
<link rel='stylesheet' id='all-css-0' href='https://www.nbcphiladelphia.com/_static/??-eJylzEtuQjEMheENlSSX+OYxqBh0Jbbj0Kh5IJKK7UNVdQGF8fnPp2+XA4++pC+9PqXJ1J34MBeuMrrmWn4W+i41aZ5T82htdOWiiQ6Zo/gULATEPapWuno0b/qf5rkOwqpy8Hh0CREZ9xzNcc/ytInXVbiKCiCOkoXohaKzFjjzq+jH70U53gAc5ewtcvL2oW9P21QHf03lM5BjIcgGYUsZyYY/89TeNwcm7iEGcwdLuJpe' type='text/css' media='all' />
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.nbcphiladelphia.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.9' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.nbcphiladelphia.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.9' id='ad-layers-js'></script>
<link rel="https://api.w.org/" href="https://www.nbcphiladelphia.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcphiladelphia.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcphiladelphia.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.7" />
<link rel="canonical" href="https://apnews.com/9d0f17b5a05134b9446e1b80b0b13682" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcphiladelphia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fangry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl%2F3093696%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcphiladelphia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fangry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl%2F3093696%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		
<!-- BEGIN Parse.ly 2.6.1 -->
<script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.nbcphiladelphia.com\/news\/sports\/angry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl\/3093696\/"},"headline":"Angry Dawgs: No. 3 Georgia Beats No. 2 Michigan 34-11 in CFP","url":"http:\/\/www.nbcphiladelphia.com\/news\/sports\/angry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl\/3093696\/","thumbnailUrl":"https:\/\/media.nbcphiladelphia.com\/2021\/12\/GettyImages-1295311174.jpg?quality=85&strip=all&resize=150%2C150","image":{"@type":"ImageObject","url":"https:\/\/media.nbcphiladelphia.com\/2021\/12\/GettyImages-1295311174.jpg?quality=85&strip=all&resize=150%2C150"},"dateCreated":"2022-01-01T04:46:01Z","datePublished":"2022-01-01T04:46:01Z","dateModified":"2022-01-01T04:46:01Z","articleSection":"Sports","author":[{"@type":"Person","name":"Ralph D. Russo"}],"creator":["Ralph D. Russo"],"publisher":{"@type":"Organization","name":"NBC10 Philadelphia","logo":"https:\/\/media.nbcphiladelphia.com\/2019\/09\/cropped-NBC_Philadelphia.png"},"keywords":["college football","georgia bulldogs","michigan wolverines","orange bowl"]}
</script>
<!-- END Parse.ly -->

<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
	.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcphiladelphia.com/2019/09/OTT-Philadelphia.png?resize=1440%2C415&quality=85&strip=all'); }
</style>
<link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/Roboto-Flex.woff2" as="font" crossorigin /><script>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</script><meta property="og:site_name" content="NBC10 Philadelphia" /><meta name="google-site-verification" content="7ux8bpU8xTfsuNKU-J96jENGRzQ-K7FY_HNakjPnuxk" /><meta property="fb:app_id" content="196375740321" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbcphiladelphia" /><meta name="twitter:creator" content="@nbcphiladelphia" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="https://www.facebook.com/nbcphiladelphia" /><meta name="description" content="Stetson Bennett threw three touchdown passes, Nakobe Dean led an angry defense and Georgia returned to its dominant ways, beating No. 2 Michigan 34-11 on Friday..." /><meta property="og:description" content="Stetson Bennett threw two touchdown passes, Nakobe Dean led an angry Georgia defense and the third-ranked Bulldogs returned to their dominant ways, beating No. 2 Michigan 34-11 in the Orange Bowl to advance to the College Football Playoff championship" /><meta name="twitter:description" content="Stetson Bennett threw two touchdown passes, Nakobe Dean led an angry Georgia defense and the third-ranked Bulldogs returned to their dominant ways, beating No. 2 Michigan 34-11 in the Orange Bowl to advance to the College Football Playoff championship" /><meta property="og:title" content="Angry Dawgs: No. 3 Georgia Beats No. 2 Michigan 34-11 in CFP" /><meta name="twitter:title" content="Angry Dawgs: No. 3 Georgia Beats No. 2 Michigan 34-11 in CFP" /><meta name="keywords" content="College Football, Georgia Bulldogs, michigan wolverines, orange bowl" /><meta property="og:url" content="https://www.nbcphiladelphia.com/news/sports/angry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl/3093696/" /><meta name="twitter:url" content="https://www.nbcphiladelphia.com/news/sports/angry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl/3093696/" /><meta name="sailthru.title" content="Angry Dawgs: No. 3 Georgia Beats No. 2 Michigan 34-11 in Orange Bowl" /><meta name="sailthru.description" content="Stetson Bennett threw three touchdown passes, Nakobe Dean led an angry defense and Georgia returned to its dominant ways, beating No. 2 Michigan 34-11 on Friday..." /><meta name="sailthru.tags" content="College Football, Georgia Bulldogs, michigan wolverines, orange bowl" /><meta name="sailthru.tags" content="College Football, Georgia Bulldogs, michigan wolverines, orange bowl" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2021-12-31T23:46:01+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="twitter:image" content="https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcphiladelphia.com\/news\/sports\/angry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl\/3093696\/","headline":"Angry Dawgs: No. 3 Georgia Beats No. 2 Michigan 34-11 in CFP","datePublished":"2021-12-31T23:46:01","dateModified":"2022-01-01T00:14:29","description":"Stetson Bennett threw three touchdown passes, Nakobe Dean led an angry defense and Georgia returned to its dominant ways, beating No. 2 Michigan 34-11 on Friday\u2026","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"College Football, Georgia Bulldogs, michigan wolverines, orange bowl","publisher":{"@type":"Organization","name":"NBC 10 Philadelphia","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcphiladelphia.com\/wp-content\/uploads\/2019\/09\/light_amp_wcau.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcphiladelphia.com\/2021\/12\/GettyImages-1295311174.jpg?quality=85&strip=all&resize=1200%2C675","width":1200},"author":{"@type":"Person","name":"Ralph D. Russo"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcphiladelphia.com/news/sports/angry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl/3093696/?amp"><link rel="icon" href="https://media.nbcphiladelphia.com/2019/09/cropped-NBC_Philadelphia.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.nbcphiladelphia.com/2019/09/cropped-NBC_Philadelphia.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcphiladelphia.com/2019/09/cropped-NBC_Philadelphia.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.nbcphiladelphia.com/2019/09/cropped-NBC_Philadelphia.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>

<body class="post-template-default single single-post postid-3093696 single-format-standard station-nbc wcau has-featured-image short-hero">
	<div class="leaderboard_ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcphiladelphia.com/">
						<img src="https://media.nbcphiladelphia.com/2021/04/Philadelphia-1.png?fit=549%2C120&#038;quality=85&#038;strip=all&#038;w=183&#038;h=40" srcset="https://media.nbcphiladelphia.com/2021/04/Philadelphia-1.png?fit=549%2C120&amp;quality=85&amp;strip=all&amp;w=183&amp;h=40 1x, https://media.nbcphiladelphia.com/2021/04/Philadelphia-1.png?fit=549%2C120&amp;quality=85&amp;strip=all&amp;w=366&amp;h=80 2x, https://media.nbcphiladelphia.com/2021/04/Philadelphia-1.png?fit=549%2C120&amp;quality=85&amp;strip=all&amp;w=549&amp;h=120 3x" alt="NBC10 Philadelphia" height="40" width="183" />					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcphiladelphia.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-primary-container"><nav id="primary-menu" class="menu"><a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Local" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/local/">Local</a></li>
<a data-lid="Sports" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent" href="/news/sports/">Sports</a></li>
<a data-lid="Entertainment" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/">Entertainment</a></li>
<a data-lid="Investigators" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigators/">Investigators</a></li>
<a data-lid="Videos" data-lpos="primary-menu" class=" menu-item menu-item-type-post_type menu-item-object-page" href="https://www.nbcphiladelphia.com/videos/">Videos</a></li>
<a data-lid="Newsletters" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.nbcphiladelphia.com/newsletters/">Newsletters</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcphiladelphia.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="Who Killed Barbara Jean?" data-lpos="trending-stories-module" href="https://www.nbcphiladelphia.com/news/local/who-killed-barbara-jean/who-killed-barbara-jean/2961590/" class="site-header__trending-nav-item">Who Killed Barbara Jean?</a>
					<a data-lid="The Lineup" data-lpos="trending-stories-module" href="https://www.nbcphiladelphia.com/tag/the-lineup/" class="site-header__trending-nav-item">The Lineup</a>
					<a data-lid="How to Use Our Roku App" data-lpos="trending-stories-module" href="https://www.nbcphiladelphia.com/news/local/who-killed-barbara-jean/how-to-watch-who-killed-barbara-jean-on-roku-and-apple-tv/2968322/" class="site-header__trending-nav-item">How to Use Our Roku App</a>
					<a data-lid="Watch on FireTV" data-lpos="trending-stories-module" href="https://www.nbcphiladelphia.com/about-nbc10/about-us/now-you-can-watch-nbc10-news-and-original-series-for-free-on-firetv/3012431/" class="site-header__trending-nav-item">Watch on FireTV</a>
					<a data-lid="Philadelphia Eagles" data-lpos="trending-stories-module" href="/news/sports/eagles/" class="site-header__trending-nav-item">Philadelphia Eagles</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather "
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="19101">
	</div>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-3093696" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcphiladelphia.com/tag/college-football/">College Football</a>						</div>
</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Angry Dawgs: No. 3 Georgia Beats No. 2 Michigan 34-11 in CFP	</h1>
			<h2 class="article-subtitle">
			Georgia (13-1) earned a rematch with Southeastern Conference nemesis Alabama (13-1) in the title game Jan. 10 in Indianapolis.		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By Ralph D. Russo							<span class="meta-dot">&bull;</span>
					
							<span class="time-wrap">
				<time class="entry-date published" datetime="2022-01-01T04:46:01-05:00">Published 46 mins ago</time>					<span class="meta-dot">&bull;</span>
				<time class="entry-date updated" datetime="2022-01-01T00:14:29-05:00">Updated 17 mins ago</time>			</span>
			</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fangry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl%2F3093696%2F&#038;Angry%20Dawgs%3A%20No.%203%20Georgia%20Beats%20No.%202%20Michigan%2034-11%20in%20CFP?_osource=db_npd_nbc_wcau_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Angry%20Dawgs%3A%20No.%203%20Georgia%20Beats%20No.%202%20Michigan%2034-11%20in%20CFP&#038;url=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fangry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl%2F3093696%2F?_osource=db_npd_nbc_wcau_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Angry%20Dawgs%3A%20No.%203%20Georgia%20Beats%20No.%202%20Michigan%2034-11%20in%20CFP%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fangry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl%2F3093696%2F?_osource=db_npd_nbc_wcau_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
</div>
		</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<figure class="article-featured-media">
	<div class="image-container">
		<img
			loading="lazy"
			srcset="https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&amp;strip=all&amp;fit=1200%2C765&amp;w=375&amp;h=211&amp;crop=1 375w, https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&amp;strip=all&amp;fit=1200%2C765&amp;w=575&amp;h=323&amp;crop=1 575w, https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&amp;strip=all&amp;fit=1200%2C765&amp;w=775&amp;h=436&amp;crop=1 775w, https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&amp;strip=all&amp;fit=1200%2C765&amp;w=975&amp;h=548&amp;crop=1 975w, https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&amp;strip=all&amp;fit=1200%2C765&amp;w=1175&amp;h=661&amp;crop=1 1175w, https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&amp;strip=all&amp;fit=1200%2C765&amp;w=1375&amp;h=773&amp;crop=1 1375w, https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&amp;strip=all&amp;fit=1200%2C765&amp;w=1575&amp;h=886&amp;crop=1 1575w, https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&amp;strip=all&amp;fit=1200%2C765&amp;w=1775&amp;h=998&amp;crop=1 1775w"
			sizes="(max-width: 768px) 100vw, (max-width: 1200px) calc(100vw - 350px), 850px"
			src="https://media.nbcphiladelphia.com/2021/12/GettyImages-1295311174.jpg?quality=85&#038;strip=all&#038;resize=320%2C180"
			alt=""
		/>
	</div>
			<figcaption>
							<cite>Getty Images</cite>
			
												<div
						class="caption"
						data-react-component="NBCTruncate"
						data-maxlines="2"
						data-maxlinesmobile="4"
						data-readmore="Read more"
						data-text="&lt;p&gt;MIAMI GARDENS, FLORIDA &#8211; JANUARY 02: A general view of the Capital One Orange Bowl logo displayed in Hard Rock Stadium prior to the game between the North Carolina Tar Heels and the Texas A&amp;M Aggies in the Capital One Orange Bowl at Hard Rock Stadium on January 02, 2021 in Miami Gardens, Florida. (Photo by Mark Brown/Getty Images)&lt;/p&gt;
"
						data-ellipsis="false">
					</div>
									</figcaption>
	</figure>
				<div class="article-content rich-text">
					
					
<p>With one overwhelming half at the Orange Bowl, No. 3 Georgia showed that a humbling loss to Alabama did not break the Bulldogs.</p>

<p>In fact, it might have made them even stronger.</p>
<div class="mobile-app-promotion">
	
<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	<strong><em>Download our local news and weather app for </em></strong><a href="https://apps.apple.com/us/app/nbc10-philadelphia-local-news/id331808522">iOS</a><em> <strong><em>or</em></strong> </em><a href="https://play.google.com/store/apps/details?id=com.nbcuni.nbcots.nbcphiladelphia.android&amp;hl=en_US&amp;gl=US">Android</a><em> </em><strong><em>— and choose the alerts you want.</em></strong></blockquote>
</div>
</div>

<p>Stetson Bennett threw three touchdown passes, Nakobe Dean led an angry defense and Georgia returned to its dominant ways, beating No. 2 Michigan 34-11 on Friday night to advance to the College Football Playoff championship.</p>

<p>“Answered a million questions about our team, bouncing back and how you play,” Georgia coach Kirby Smart said. "We’ve got a lot of high-character guys on this team and they played their tail off today.”</p>
<div class="recirc-module">
	<h3 class="recirc__heading">Sports</h3>
	<p class="recirc__subheading">In partnership with NBC Sports Philadelphia</p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Run Tide! No. 1 Bama Over Non-P5 Cincy 27-6 in CFP Semi" href="https://www.nbcphiladelphia.com/news/sports/run-tide-no-1-bama-over-cincy-27-6-in-cfp-semi/3093650/">
							<img class="post__image" srcset="https://media.nbcphiladelphia.com/2021/12/AP_21365781859796.jpg?quality=85&amp;strip=all&amp;crop=0px%2C152px%2C5555px%2C3125px&amp;resize=200%2C113 200w, https://media.nbcphiladelphia.com/2021/12/AP_21365781859796.jpg?quality=85&amp;strip=all&amp;crop=0px%2C152px%2C5555px%2C3125px&amp;resize=400%2C225 400w, https://media.nbcphiladelphia.com/2021/12/AP_21365781859796.jpg?quality=85&amp;strip=all&amp;crop=0px%2C152px%2C5555px%2C3125px&amp;resize=600%2C338 600w, " src="https://media.nbcphiladelphia.com/2021/12/AP_21365781859796.jpg?quality=85&#038;strip=all&#038;crop=0px%2C152px%2C5555px%2C3125px&#038;resize=600%2C338" alt="" sizes="200px" loading="lazy" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="College Football Playoff" class="post__tag" href="https://www.nbcphiladelphia.com/tag/college-football-playoff/">College Football Playoff</a>
																			<span class="post__date post__date--has-category">
								4 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Run Tide! No. 1 Bama Over Non-P5 Cincy 27-6 in CFP Semi" class="post__title--link" href="https://www.nbcphiladelphia.com/news/sports/run-tide-no-1-bama-over-cincy-27-6-in-cfp-semi/3093650/">
								Run Tide! No. 1 Bama Over Non-P5 Cincy 27-6 in CFP Semi							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Steve Kornacki Breaks Down the Eagles&#039; Chances of a Playoff Spot" href="https://www.nbcphiladelphia.com/news/sports/eagles/steve-kornacki-breaks-down-the-eagles-chances-of-a-playoff-spot/3093595/">
							<img class="post__image" srcset="https://media.nbcphiladelphia.com/2021/12/14045341474-1080pnbcstations.jpg?quality=85&amp;strip=all&amp;resize=200%2C113 200w, https://media.nbcphiladelphia.com/2021/12/14045341474-1080pnbcstations.jpg?quality=85&amp;strip=all&amp;resize=400%2C225 400w, https://media.nbcphiladelphia.com/2021/12/14045341474-1080pnbcstations.jpg?quality=85&amp;strip=all&amp;resize=600%2C338 600w, " src="https://media.nbcphiladelphia.com/2021/12/14045341474-1080pnbcstations.jpg?quality=85&#038;strip=all&#038;resize=600%2C338" alt="" sizes="200px" loading="lazy" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Eagles" class="post__tag" href="https://www.nbcphiladelphia.com/tag/eagles/">Eagles</a>
																			<span class="post__date post__date--has-category">
								6 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Steve Kornacki Breaks Down the Eagles&#039; Chances of a Playoff Spot" class="post__title--link" href="https://www.nbcphiladelphia.com/news/sports/eagles/steve-kornacki-breaks-down-the-eagles-chances-of-a-playoff-spot/3093595/">
								Steve Kornacki Breaks Down the Eagles&#039; Chances of a Playoff Spot							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<p>Georgia (13-1) earned a rematch with Southeastern Conference nemesis Alabama (13-1) in the title game Jan. 10 in Indianapolis.</p>

<p>It was 27 days ago the Crimson Tide rolled through the Bulldogs, shattering their air of invincibility after a 12-0 regular season in which they were hardly challenged.</p>

<p>“All our guys did was work,” Smart said about how they responded to the loss and three weeks of being asked what went wrong.</p>

<p>The Bulldogs quickly answered any questions about whether the damage from that 41-24 setback would linger.</p>

<p>Georgia became the first team in the eight-year history of the CFP to score on each of its first five possessions and led 27-3 at halftime.</p>

<p>“We knew we were better than what we showed that last game,” Bennett said.</p>

<p>Michigan (12-2) entered its first playoff appearance off a milestone season, having ended a long drought against rival Ohio State on the way to winning the Big Ten.</p>

<p>“Let'er rip,” Michigan coach Jim Harbaugh told ESPN moments before kickoff.</p>

<p>The Bulldogs most certainly did, playing like a team out to prove a point.</p>

<p>Georgia scored touchdowns the first two times it had the ball, moving it at will against Heisman Trophy runner-up Aidan Hutchinson and the Michigan defense.</p>

<p>Bennett found freshman tight end Brock Bowers free in the flats for an 8-yard touchdown pass to cap an 80-yard opening drive.</p>

<p>"That set the tone for the game,” Smart said.</p>

<p>Georgia grabbed a two-touchdown lead, hitting Michigan with some of the trickery the Wolverines have used so well this season. Tailback Kenny McIntosh swept to the right and let loose a perfect pass to Adonai Mitchell for an 18-yard TD that made it 14-0 less than five minutes into the game.</p>

<p>The Wolverines had rolled to their first Big Ten championship since 2004 without trailing by as many as seven points this season.</p>

<p>“I mean, we gave everything we got, and we got beat tonight,” quarterback Cade McNamara said. “But I think once we give it a little time, we’ll be able to appreciate a lot of the great things we were able to accomplish this season."</p>

<p>The Bulldogs tacked on field goals on their next two possessions and Bennett connected on a 57-yard touchdown pass to Jermaine Burton streaking down the sideline to make it 27-3 with 1:38 left in the half.</p>

<p>And that was was pretty much that. The Bulldogs dominated in every way, outgaining the Wolverines 330-101 in the first 30 minutes.</p>

<p>“I thought our front controlled line of scrimmage. I thought our offensive line controlled the line of scrimmage,” Smart said. “That’s a total team effort.”</p>

<p>The Georgia defense that was setting an historic pace, allowing less than a touchdown per game before getting shredded by Alabama, smothered a Michigan offense built to bully opponents.</p>

<p>The Bulldogs were having none of that.</p>

<p>Dean, the Butkus Award-winning linebacker, diagnosed plays before the snap and chased down ball carriers from sideline to sideline. </p>

<p>Dean said he made note of how heading into this game, for the first time all season, Georgia's defensive dominance seemed to be in doubt.</p>

<p>“We always want to play with a chip on our shoulder,” Dean said.</p>

<p>Massive nose tackle Jordan Davis collapsed the middle of a Michigan offensive line that won the Joe Moore Award as the best in the country.</p>

<p>“That was our plan going in, being a physical, more dominant front,” the All-American Davis said.</p>

<p>Cornerback Derion Kendrick, a transfer for Clemson, had two interceptions and was the defensive player of the game.</p>

<p>The Wolverines finished with 88 yards rushing after coming in averaging 223 per game. McNamara was 11 for 19 for 106 yards passing.</p>

<p>Simply, it was no contest and now the Bulldogs will get a shot at redemption against Alabama, trying to win their first national title since 1980. </p>

<p>All that stands in the way is the most accomplished dynasty in the history of college football, the rival Smart, a longtime Nick Saban assistant at Alabama, has tried to model his program after.</p>

<p>Smart ducked the celebratory Gatorade bath after the game, saying he wanted to get a real shower and get to work on catching the team the Bulldogs have been chasing for five years.</p>

<p>"They got a five, six-hour head start on us," Smart said.</p>

<p>Georgia opened as 2 1/2-point favorite, according to FanDuel Sportsbook.</p>

<p>THE TAKEAWAY</p>

<p>Georgia: There was plenty of talk about whether Bennett should remain the Bulldogs' starting quarterback after he threw two interceptions against Alabama. Georgia fans wondered if it was time to make the switch back to USC transfer JT Daniels, who was QB1 to start the season before an injury opened the door for Bennett.</p>

<p>The former walk-on completed his first nine passes against Michigan on the way to 307 yards and showed more than enough arm strength on a 53-yard bomb to James Cook in the second quarter. Bennett was named offensive MVP.</p>

<p>Michigan: The 2021 season will provide plenty for the Wolverines to look back upon fondly. </p>

<p>“This is the start,” Harbaugh told ESPN afterward. “In Michigan history, it is one of the best teams ever.”</p>

<p>The Orange Bowl showed that closing the gap on Ohio State is one thing, but there are two teams currently at the top of college football in an entirely different class as the rest. </p>

<p>UP NEXT</p>

<p>Georgia: The Bulldogs will face Alabama for the second time in the CFP title game. The Bulldogs have lost seven straight against the Tide, including the 2017 championship game in overtime.</p>

<p>Michigan: The Wolverines open the 2022 season at home against Colorado State.</p>

<p>___</p>

<p>Follow Ralph D. Russo at https://twitter.com/ralphDrussoAP and listen at http://www.appodcasts.com</p>

<p>___</p>

<p>More AP college football: https://apnews.com/hub/college-football and https://twitter.com/AP_Top25. Sign up for the AP’s college football newsletter: https://apnews.com/cfbtop25 </p>

									</div>
							<div class="article-copyright">Copyright AP - Associated Press</div>
				<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcphiladelphia.com/tag/college-football/">College Football</a><a class="article-tags__tag" href="https://www.nbcphiladelphia.com/tag/georgia-bulldogs/">Georgia Bulldogs</a><a class="article-tags__tag" href="https://www.nbcphiladelphia.com/tag/michigan-wolverines/">michigan wolverines</a><a class="article-tags__tag" href="https://www.nbcphiladelphia.com/tag/orange-bowl/">orange bowl</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fangry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl%2F3093696%2F&#038;Angry%20Dawgs%3A%20No.%203%20Georgia%20Beats%20No.%202%20Michigan%2034-11%20in%20CFP?_osource=db_npd_nbc_wcau_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Angry%20Dawgs%3A%20No.%203%20Georgia%20Beats%20No.%202%20Michigan%2034-11%20in%20CFP&#038;url=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fangry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl%2F3093696%2F?_osource=db_npd_nbc_wcau_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Angry%20Dawgs%3A%20No.%203%20Georgia%20Beats%20No.%202%20Michigan%2034-11%20in%20CFP%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fangry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl%2F3093696%2F?_osource=db_npd_nbc_wcau_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
						_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'text'
			});
					};
	</script>
		<div id="mobile-native-below-article"></div>
	<script type="text/javascript">
		var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbs-feed-03-mobile',
				container: 'mobile-native-below-article',
				placement: 'Below Article Thumbnails - Fallback',
				target_type: 'text'
			});
		};
	</script>
					</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="nbc_most_popular-2" class="widget widget_nbc_most_popular"><div class="nbc-most-popular" data-react-component="MostPopular" data-title="Trending Stories" data-include-sponsored="true" data-beforetext="Presented By"></div></section><section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_436" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_436', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Philadelphia, PA"></div>
	<a class="weather-module__conditions" href="https://www.nbcphiladelphia.com/weather/">
		<div data-react-component="IframeConditions" data-location="19101"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_895" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_895', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-9" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilemultibox_291" class=" gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_291', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script></section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-1861572874" class="module-civicScience" data-tgtid="67ed2dfc-f223-44f4-f9e9-6ebcf5490750"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_845" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_845', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_534" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_534', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_999" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_999', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcphiladelphia.com/" class="site-footer__logo">
					<img
						src="https://media.nbcphiladelphia.com/2021/04/Philadelphia@3x.png?fit=549%2C120&#038;quality=85&#038;strip=all"
						alt="NBC10 Philadelphia"
						loading="lazy"
					/>
				</a>
			
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="https://www.facebook.com/nbcphiladelphia" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbcphiladelphia" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbcphiladelphia" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2256341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2256341"><a href="https://www.nbcphiladelphia.com/send-feedback/">Share a News Tip or Feedback</a></li>
<li id="menu-item-2242054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2242054"><a href="/investigations/submit-tip/">Share a Tip for the NBC10 Investigators</a></li>
<li id="menu-item-2241580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2241580"><a href="https://www.nbcphiladelphia.com/newsletters/">Newsletters</a></li>
<li id="menu-item-2241590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2241590"><a href="https://www.nbcphiladelphia.com/contact-us/">Connect With Us</a></li>
<li id="menu-item-2260640" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2260640"><a href="https://comcastcentercampus.com/">About the Comcast Center Campus</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-1979913" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1979913"><a href="https://publicfiles.fcc.gov/tv-profile/WCAU">WCAU Public Inspection File</a></li>
<li id="menu-item-1979916" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1979916"><a href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_10_Philadelphia/">Privacy Policy</a></li>
<li id="menu-item-2223070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2223070"><a href="https://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC_10_Philadelphia/">Do Not Sell My Personal Information</a></li>
<li id="menu-item-1979950" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1979950"><a href="https://www.nbcphiladelphia.com/wcau-employment-information/">WCAU EMPLOYMENT INFORMATION</a></li>
<li id="menu-item-2578140" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2578140"><a href="https://www.nbcphiladelphia.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-1979951" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1979951"><a href="https://www.nbcphiladelphia.com/terms-of-service/">TERMS OF SERVICE</a></li>
<li id="menu-item-1979922" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1979922"><a href="mailto:WCAUViewerMail.Advertising@nbcuni.com?subject=Advertise%20with%20Us%20HP/">Advertise with us</a></li>
<li id="menu-item-1979952" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1979952"><a href="https://www.nbcphiladelphia.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-2475593" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2475593"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_10_Philadelphia">CA Notice</a></li>
<li id="menu-item-1979918" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1979918"><a href="https://info.evidon.com/pub_info/209?v=1&#038;nt=0&#038;nw=false/">AdChoices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2022 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "nbcphiladelphia.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "sports";
		_sf_async_config.authors  = "Ralph D. Russo";
		_sf_async_config.title    = "Angry Dawgs: No. 3 Georgia Beats No. 2 Michigan 34-11 in CFP";
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
			(function() {
				var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
					usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
					csUCFR = '1YYN' === usPrivacy ? '0': '',
					s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];

				window._comscore = window._comscore || [];

				window._comscore.push({
					c1: "2",
					c2: "6035083",
					cs_ucfr: csUCFR,
				});

				s.async = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
		(function() {
			window._taboola = window._taboola || [];
			window._newsroom = window._newsroom || [];
			var loaderUrl = 'https://cdn.taboola.com/libtrc/nbcots-network/loader.js';
			const taboola_config = {};

			taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '3093696' );
			taboola_config['url'] = document.URL;
			taboola_config['tracking'] = '_osource=taboola-recirc';
			_taboola.push(taboola_config);

			
			!function (e, f, u, i) {
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			loaderUrl,
			'tb_loader_script');

			!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			"\/\/c2.taboola.com\/nr\/nbcots-wcau\/newsroom.js");
		}());
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcphiladelphia.com/news/sports/angry-dawgs-no-3-georgia-beats-no-2-michigan-34-11-in-orange-bowl/3093696/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcphiladelphia.com/">
					<img
						src="https://media.nbcphiladelphia.com/2021/04/Philadelphia@3x.png?fit=549%2C120&#038;quality=85&#038;strip=all"
						alt="NBC10 Philadelphia"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcphiladelphia.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="Tokyo Olympics" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/tokyo-summer-olympics/">
					Tokyo Olympics				</a>
							<a data-lid="U.S. and World" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/national-international/">
					U.S. and World				</a>
							<a data-lid="NBCLX" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a data-lid="Politics" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/politics/">
					Politics				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a data-lid="Weather Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a data-lid="School Closings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/school-closings/">
					School Closings				</a>
							<a data-lid="See It, Share It" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.nbcphiladelphia.com/ugc/">
					See It, Share It				</a>
							<a data-lid="Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a data-lid="Phillies" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/phillies/">
					Phillies				</a>
							<a data-lid="Eagles" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/eagles/">
					Eagles				</a>
							<a data-lid="Sixers" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/sixers/">
					Sixers				</a>
							<a data-lid="Flyers" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/flyers/">
					Flyers				</a>
							<a data-lid="NBC Sports Philadelphia" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcsports.com/philadelphia">
					NBC Sports Philadelphia				</a>
							<a data-lid="Investigators" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/investigators/">
					Investigators				</a>
							<a data-lid="NBC10 Responds" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/investigators/consumer/">
					NBC10 Responds				</a>
							<a data-lid="Watch The Lineup" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/the-lineup/">
					Watch The Lineup				</a>
							<a data-lid="Entertainment" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/">
					Entertainment				</a>
							<a data-lid="Philly Live" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/entertainment/philly-live/">
					Philly Live				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="Share a News Tip or Feedback" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcphiladelphia.com/send-feedback/">
					Share a News Tip or Feedback				</a>
							<a data-lid="Share a Consumer Complaint" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Share a Consumer Complaint				</a>
							<a data-lid="Share Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcphiladelphia.com/ugc/">
					Share Photos and Video				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcphiladelphia.com/newsletters/">
					Newsletters				</a>
							<a data-lid="Cozi TV" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://cozitv.com/">
					Cozi TV				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="https://www.facebook.com/nbcphiladelphia" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbcphiladelphia" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbcphiladelphia" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us"
	>
	Contact Us</a>
<link rel='stylesheet' id='all-css-0' href='https://www.nbcphiladelphia.com/_static/??-eJydzlsOwiAQheENWeiF0uHBuAPjFpgBIgmXpkw17t764AL0+fz5cuRz7agW9oUl3332TRakrrHlWIukFD8L7jE5Sa3JXBvf6ronu4mx93YJJixGQRhgGgGUyLGIIzzJH+FQK/tNODcFVIr0TKTBmkGj+99Mr7rz1T6EOr4aQrLzgQJq5R1+2Us+D1r1ZgYD/RvKsV7a' type='text/css' media='all' />
<script src='https://www.nbcphiladelphia.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/i18n.min.js?ver=4ab02c8fd541b8cfb8952fe260d21f16' id='wp-i18n-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.21' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/url.min.js?ver=d80b474ffb72c3b6933165cc1b3419f6' id='wp-url-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/hooks.min.js?ver=63769290dead574c40a54748f22ada71' id='wp-hooks-js'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/api-fetch.min.js?ver=0bb73d10eeea78a4d642cdd686ca7f59' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/common.2693f9b171added63e6f.bundle.min.js?ver=1.0.2' id='nbc-common-js-js'></script>
<script async src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.87a2ab5dafb347c6e53b.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script async src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/global.190ccc38701c42c4d6d3.bundle.min.js?ver=1.0.2' id='nbc-global-js-js'></script>
<script async src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/article.56b83fbb92bec651acb6.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/analytics.9ba537a09f8b0b5ceac2.bundle.min.js?ver=1.0.2' id='nbc-analytics-js-js'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.7' id='sharethrough-js'></script>
<script async src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/flyoutNav.57fd800295608226f92a.bundle.min.js?ver=1.0.2' id='nbc-flyout-nav-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/articleContent.002368ae3a0d6363e579.bundle.min.js?ver=1.0.2' id='nbc-article-content-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/185796-256714881512110.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/wp-embed.min.js?ver=5.5.7' id='wp-embed-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/mostPopular.24581aafd2c2eedb4e36.bundle.min.js?ver=1.0.2' id='nbc-most-popular-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/civicScience.4db1dfb9fe92d553e9e3.bundle.min.js?ver=1.0.2' id='civic-science-js'></script>
<script id='wp-parsely-api-js-extra'>
var wpParsely = {"apikey":"nbcphiladelphia.com"};
</script>
<script data-cfasync="false" src='https://www.nbcphiladelphia.com/wp-content/mu-plugins/wp-parsely-2.6/build/init-api.js?ver=2.6.1' id='wp-parsely-api-js'></script>
<script data-cfasync="false" data-parsely-site="nbcphiladelphia.com" src='https://cdn.parsely.com/keys/nbcphiladelphia.com/p.js?ver=2.6.1' id="parsely-cfg"></script>
<script src='https://stats.wp.com/e-202252.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'165596172',post:'3093696',tz:'-5',srv:'www.nbcphiladelphia.com'} ]);
	_stq.push([ 'clickTrackerInit', '165596172', '3093696' ]);
</script>

</body>
</html>
