<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		
	<link rel="profile" href="https://gmpg.org/xfn/11">
		<title>NFL Rookie of the Year: Can Mac Jones Pass Ja&#8217;Marr Chase? &#8211; NBC10 Philadelphia</title>
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//z.moatads.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC10 Philadelphia &raquo; Feed" href="https://www.nbcphiladelphia.com/?rss=y" />
<link rel='stylesheet' id='all-css-0' href='https://www.nbcphiladelphia.com/_static/??-eJylzElOBCAQheEL2UzFUCyMC09SFKBEBiMYr99tjAewXb//ffLr/cJrnjKPPK9llC1n4ss+dNqaknv7XtJn61ny3pLXGGsKH1X0xBxLyAgWiVwUo01xax7kH82XvhJ1AQpRVUTtOECBnErMd5v0cRr3IlJQBFgjJTCQbS4Gy3/R55+L8Kyt9anWAMQ5AIDVd9upL37bombvkjGavS6VQAV04dd8Go/ag9PBoMIrfy2ZBg==' type='text/css' media='all' />
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script src='https://www.nbcphiladelphia.com/wp-content/plugins/ad-layers-nbc/js/ad-layers-dfp.js?ver=0.0.9' id='ad-layers-dfp-js'></script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script src='https://www.nbcphiladelphia.com/wp-content/plugins/ad-layers-nbc/js/ad-layers.js?ver=0.0.9' id='ad-layers-js'></script>
<link rel="https://api.w.org/" href="https://www.nbcphiladelphia.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcphiladelphia.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcphiladelphia.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.6" />
<link rel="canonical" href="https://www.nbcsports.com/boston/patriots/nfl-rookie-year-odds-can-mac-jones-pass-jamarr-chase" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcphiladelphia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fnfl-rookie-of-the-year-2021-mac-jones-jamarr-chase%2F3015750%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcphiladelphia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fnfl-rookie-of-the-year-2021-mac-jones-jamarr-chase%2F3015750%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		
<!-- BEGIN Parse.ly 2.6.1 -->
<script type="application/ld+json">
{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.nbcphiladelphia.com\/news\/sports\/nfl-rookie-of-the-year-2021-mac-jones-jamarr-chase\/3015750\/"},"headline":"NFL Rookie of the Year: Can Mac Jones Overtake Ja'Marr Chase?","url":"http:\/\/www.nbcphiladelphia.com\/news\/sports\/nfl-rookie-of-the-year-2021-mac-jones-jamarr-chase\/3015750\/","thumbnailUrl":"https:\/\/media.nbcphiladelphia.com\/2021\/10\/Mac-Jones-USATSI_17020481.jpg?quality=85&strip=all&resize=150%2C150","image":{"@type":"ImageObject","url":"https:\/\/media.nbcphiladelphia.com\/2021\/10\/Mac-Jones-USATSI_17020481.jpg?quality=85&strip=all&resize=150%2C150"},"dateCreated":"2021-10-27T10:25:00Z","datePublished":"2021-10-27T10:25:00Z","dateModified":"2021-10-27T10:25:00Z","articleSection":"Sports","author":[{"@type":"Person","name":"Stephen Coulter"}],"creator":["Stephen Coulter"],"publisher":{"@type":"Organization","name":"NBC10 Philadelphia","logo":"https:\/\/media.nbcphiladelphia.com\/2019\/09\/cropped-NBC_Philadelphia.png"},"keywords":["mac jones","new england patriots","nfl","nfl rookie of the year"]}
</script>
<!-- END Parse.ly -->

<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
	.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcphiladelphia.com/2019/09/OTT-Philadelphia.png?resize=1440%2C415&quality=85&strip=all'); }
</style>
<link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/media/Roboto-Flex.woff2" as="font" crossorigin /><script>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</script><meta property="og:site_name" content="NBC10 Philadelphia" /><meta name="google-site-verification" content="7ux8bpU8xTfsuNKU-J96jENGRzQ-K7FY_HNakjPnuxk" /><meta property="fb:app_id" content="196375740321" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbcphiladelphia" /><meta name="twitter:creator" content="@nbcphiladelphia" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="https://www.facebook.com/nbcphiladelphia" /><meta name="description" content="The 2021 NFL Rookie of the Year is a battle between Patriots quarterback Mac Jones and Bengals wide receiver Ja&#039;Marr Chase. Here&#039;s the case for both first-year..." /><meta property="og:description" content="The 2021 NFL Rookie of the Year is a battle between Patriots quarterback Mac Jones and Bengals wide receiver Ja&#039;Marr Chase. Here&#039;s the case for both first-year stars." /><meta name="twitter:description" content="The 2021 NFL Rookie of the Year is a battle between Patriots quarterback Mac Jones and Bengals wide receiver Ja&#039;Marr Chase. Here&#039;s the case for both first-year stars." /><meta property="og:title" content="NFL Rookie of the Year: Can Mac Jones Pass Ja&#039;Marr Chase?" /><meta name="twitter:title" content="NFL Rookie of the Year: Can Mac Jones Pass Ja&#039;Marr Chase?" /><meta name="keywords" content="MAC Jones, New England Patriots, nfl, NFL Rookie of the Year" /><meta property="og:url" content="https://www.nbcphiladelphia.com/news/sports/nfl-rookie-of-the-year-2021-mac-jones-jamarr-chase/3015750/" /><meta name="twitter:url" content="https://www.nbcphiladelphia.com/news/sports/nfl-rookie-of-the-year-2021-mac-jones-jamarr-chase/3015750/" /><meta name="sailthru.title" content="NFL Rookie of the Year: Can Mac Jones Pass Ja&#039;Marr Chase?" /><meta name="sailthru.description" content="The 2021 NFL Rookie of the Year is a battle between Patriots quarterback Mac Jones and Bengals wide receiver Ja&#039;Marr Chase. Here&#039;s the case for both first-year..." /><meta name="sailthru.tags" content="MAC Jones, New England Patriots, nfl, NFL Rookie of the Year" /><meta name="sailthru.tags" content="MAC Jones, New England Patriots, nfl, NFL Rookie of the Year" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2021-10-27T06:25:00+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.nbcphiladelphia.com/2021/10/Mac-Jones-USATSI_17020481.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="twitter:image" content="https://media.nbcphiladelphia.com/2021/10/Mac-Jones-USATSI_17020481.jpg?quality=85&#038;strip=all&#038;resize=1200%2C675" /><meta name="taboola_lead" content="video" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcphiladelphia.com\/news\/sports\/nfl-rookie-of-the-year-2021-mac-jones-jamarr-chase\/3015750\/","headline":"NFL Rookie of the Year: Can Mac Jones Overtake Ja'Marr Chase?","datePublished":"2021-10-27T06:25:00","dateModified":"2021-10-27T06:25:00","description":"The 2021 NFL Rookie of the Year is a battle between Patriots quarterback Mac Jones and Bengals wide receiver Ja'Marr Chase. Here's the case for both first-year\u2026","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"MAC Jones, New England Patriots, nfl, NFL Rookie of the Year","publisher":{"@type":"Organization","name":"NBC 10 Philadelphia","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcphiladelphia.com\/wp-content\/uploads\/2019\/09\/light_amp_wcau.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcphiladelphia.com\/2021\/10\/Mac-Jones-USATSI_17020481.jpg?quality=85&strip=all&resize=1200%2C675","width":1200},"video":{"@type":"VideoObject","contentUrl":"https:\/\/www.nbcphiladelphia.com\/news\/sports\/nfl-rookie-of-the-year-2021-mac-jones-jamarr-chase\/3015750\/","description":"Who has the best odds to win NFL Offensive Rookie of the Year? Here&#8217;s where Patriots quarterback Mac Jones ranks among the top contenders.","duration":"PT01M56S","name":"NFL Rookie of the Year: Can Mac Jones Overtake Ja'Marr Chase?","thumbnailUrl":"https:\/\/media.nbcphiladelphia.com\/2021\/10\/Mac-Jones-USATSI_17020481.jpg?quality=85&strip=all&resize=1200%2C675","uploadDate":"2021-10-27T06:25:00"},"author":{"@type":"Person","name":"Darren Hartwell"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcphiladelphia.com/news/sports/nfl-rookie-of-the-year-2021-mac-jones-jamarr-chase/3015750/?amp"><link rel="icon" href="https://media.nbcphiladelphia.com/2019/09/cropped-NBC_Philadelphia.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.nbcphiladelphia.com/2019/09/cropped-NBC_Philadelphia.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcphiladelphia.com/2019/09/cropped-NBC_Philadelphia.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.nbcphiladelphia.com/2019/09/cropped-NBC_Philadelphia.png?fit=270%2C270&#038;quality=85&#038;strip=all" />
</head>

<body class="post-template-default single single-post postid-3015750 single-format-standard station-nbc wcau has-featured-image short-hero">
	<div class="leaderboard_ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcphiladelphia.com/">
						<img src="https://media.nbcphiladelphia.com/2021/04/Philadelphia-1.png?fit=549%2C120&#038;quality=85&#038;strip=all&#038;w=183&#038;h=40" srcset="https://media.nbcphiladelphia.com/2021/04/Philadelphia-1.png?fit=549%2C120&amp;quality=85&amp;strip=all&amp;w=183&amp;h=40 1x, https://media.nbcphiladelphia.com/2021/04/Philadelphia-1.png?fit=549%2C120&amp;quality=85&amp;strip=all&amp;w=366&amp;h=80 2x, https://media.nbcphiladelphia.com/2021/04/Philadelphia-1.png?fit=549%2C120&amp;quality=85&amp;strip=all&amp;w=549&amp;h=120 3x" alt="NBC10 Philadelphia" height="40" width="183" />					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcphiladelphia.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-primary-container"><nav id="primary-menu" class="menu"><a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Local" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/local/">Local</a></li>
<a data-lid="Sports" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent" href="/news/sports/">Sports</a></li>
<a data-lid="Entertainment" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/entertainment/">Entertainment</a></li>
<a data-lid="Investigators" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigators/">Investigators</a></li>
<a data-lid="Videos" data-lpos="primary-menu" class=" menu-item menu-item-type-post_type menu-item-object-page" href="https://www.nbcphiladelphia.com/videos/">Videos</a></li>
<a data-lid="Newsletters" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="https://www.nbcphiladelphia.com/newsletters/">Newsletters</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcphiladelphia.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="Who Killed Barbara Jean?" data-lpos="trending-stories-module" href="https://www.nbcphiladelphia.com/news/local/who-killed-barbara-jean/who-killed-barbara-jean/2961590/" class="site-header__trending-nav-item">Who Killed Barbara Jean?</a>
					<a data-lid="The Lineup" data-lpos="trending-stories-module" href="https://www.nbcphiladelphia.com/tag/the-lineup/" class="site-header__trending-nav-item">The Lineup</a>
					<a data-lid="How to Use Our Roku App" data-lpos="trending-stories-module" href="https://www.nbcphiladelphia.com/news/local/who-killed-barbara-jean/how-to-watch-who-killed-barbara-jean-on-roku-and-apple-tv/2968322/" class="site-header__trending-nav-item">How to Use Our Roku App</a>
					<a data-lid="Watch on FireTV" data-lpos="trending-stories-module" href="https://www.nbcphiladelphia.com/about-nbc10/about-us/now-you-can-watch-nbc10-news-and-original-series-for-free-on-firetv/3012431/" class="site-header__trending-nav-item">Watch on FireTV</a>
					<a data-lid="Meet Katie Couric" data-lpos="trending-stories-module" href="https://www.nbcphiladelphia.com/about-nbc10/on-air/contests/enter-for-a-chance-to-win-a-vip-experience-to-katie-courics-going-there-tour-2021/3008912/" class="site-header__trending-nav-item">Meet Katie Couric</a>
					<a data-lid="Philadelphia Eagles" data-lpos="trending-stories-module" href="/news/sports/eagles/" class="site-header__trending-nav-item">Philadelphia Eagles</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather "
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="19101">
	</div>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-3015750" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcphiladelphia.com/tag/nfl-rookie-of-the-year/">NFL Rookie of the Year</a>						</div>
</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		NFL Rookie of the Year: Can Mac Jones Overtake Ja'Marr Chase?	</h1>
			<h2 class="article-subtitle">
			An Alabama quarterback and a LSU pass catcher look to battle for top NFL rookie honor in 2021		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By Darren Hartwell							<span class="meta-dot">&bull;</span>
					
							<span class="time-wrap">
				<time class="entry-date published" datetime="2021-10-27T10:25:00-04:00">Published October 27, 2021</time>			</span>
			</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fnfl-rookie-of-the-year-2021-mac-jones-jamarr-chase%2F3015750%2F&#038;NFL%20Rookie%20of%20the%20Year%3A%20Can%20Mac%20Jones%20Overtake%20Ja%27Marr%20Chase%3F?_osource=db_npd_nbc_wcau_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=NFL%20Rookie%20of%20the%20Year%3A%20Can%20Mac%20Jones%20Overtake%20Ja%27Marr%20Chase%3F&#038;url=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fnfl-rookie-of-the-year-2021-mac-jones-jamarr-chase%2F3015750%2F?_osource=db_npd_nbc_wcau_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=NFL%20Rookie%20of%20the%20Year%3A%20Can%20Mac%20Jones%20Overtake%20Ja%27Marr%20Chase%3F%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fnfl-rookie-of-the-year-2021-mac-jones-jamarr-chase%2F3015750%2F?_osource=db_npd_nbc_wcau_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
</div>
		</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<div class="video-flyout" data-component="videoFlyout">
	<figure class="article-featured-media video-lead">
		<div
			data-react-component="VideoPlayer"
		data-meta="{&quot;amp_status&quot;:&quot;&quot;,&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;1:1:6565151&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_linkout_title&quot;:&quot;&quot;,&quot;nbc_linkout_url&quot;:&quot;&quot;,&quot;nbc_linkout_excerpt_link&quot;:&quot;&quot;,&quot;nbc_primary_category_id&quot;:12538,&quot;nbc_primary_tag_id&quot;:379,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;1&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;1:1:12538&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBCUniversal Media, LLC&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;post_video_prompt&quot;:&quot;&quot;,&quot;nbc_checkout_experience_enabled&quot;:false,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;&quot;,&quot;mp4_url&quot;:&quot;http:\/\/nbclim-download.edgesuite.net\/Prod\/NBCU_LM_VMS\/862\/671\/DIT_RSN_NAT_NFLWeek8Preview_102621_BF__381615.mp4&quot;,&quot;mpx_download_pid&quot;:&quot;tDa__uE3WAzJ&quot;,&quot;mpx_download_pid_high&quot;:&quot;AJwEGoRqFt31&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;RbkJHiZXzPLN&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.nbcphiladelphia.com\/2021\/10\/DIT_RSN_BOS_NFLWeek8Preview_102621_BF.jpg?quality=85&amp;strip=all&amp;resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;CcqCIDxCz6FU&quot;,&quot;pid_streaming_web_medium&quot;:&quot;RbkJHiZXzPLN&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;NBCU LM VMS&quot;,&quot;video_captions&quot;:&quot;&quot;,&quot;video_id&quot;:&quot;1967998531809_674&quot;,&quot;video_length&quot;:&quot;116450&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;short_video_excerpt&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_low&quot;:&quot;&quot;,&quot;pid_streaming_web_mobile_low&quot;:&quot;&quot;,&quot;mpx_download_pid_mobile_standard&quot;:&quot;&quot;,&quot;pid_streaming_mobile_standard&quot;:&quot;&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_1967998531809&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}"
	data-livestream="false"
	data-title="What to Watch in Week 8 of the NFL Season"
	data-vidcid="1:12:3014527"
	data-vidurl="https://www.nbcphiladelphia.com/news/sports/what-to-watch-in-week-8-of-the-nfl-season/3014527/"
			data-islead="true"
		data-catnames="{&quot;282048&quot;:&quot;News&quot;,&quot;383&quot;:&quot;Sports&quot;}"
	data-tagnames="{&quot;12428&quot;:&quot;Chicago Bears&quot;,&quot;5607&quot;:&quot;Dallas Cowboys&quot;,&quot;2119&quot;:&quot;Denver Broncos&quot;,&quot;100615&quot;:&quot;Detroit Lions&quot;,&quot;1356&quot;:&quot;football&quot;,&quot;363285&quot;:&quot;houston texans&quot;,&quot;1493&quot;:&quot;Indianapolis Colts&quot;,&quot;13165&quot;:&quot;Kansas City Chiefs&quot;,&quot;430913&quot;:&quot;Los Angeles Chargers&quot;,&quot;569&quot;:&quot;Los Angeles Rams&quot;,&quot;12095&quot;:&quot;Minnesota Vikings&quot;,&quot;571&quot;:&quot;New England Patriots&quot;,&quot;35097&quot;:&quot;New York Giants&quot;,&quot;379&quot;:&quot;nfl&quot;,&quot;1299&quot;:&quot;Philadelphia Eagles&quot;,&quot;17805&quot;:&quot;San Francisco 49ers&quot;,&quot;33715&quot;:&quot;Tennessee Titans&quot;,&quot;352053&quot;:&quot;washington football team&quot;}"
	data-customdata="{}"
			data-autoplay="true"
				data-cplay="true"
	></div>
			<figcaption>
									<cite>NBCUniversal Media, LLC</cite>
				
															<div
							class="caption"
							data-react-component="NBCTruncate"
							data-maxlines="2"
							data-maxlinesmobile="4"
							data-readmore="Read more"
							data-text="The 2021 NFL Rookie of the Year is a two-way battle between Patriots quarterback Mac Jones and Bengals wide receiver Ja&#039;Marr Chase."
							data-ellipsis="false">
						</div>
												</figcaption>
						<button class="video-flyout__dismiss"><span class="icon icon-times"></span></button>
			</figure>
</div>
				<div class="article-content rich-text">
					
					
<iframe src="https://www.nbcsports.com/vplayer/p/BxmELC/newengland_embed/select/media/LHx9gsAQSOnc?form=html&amp;autoPlay=true&amp;ssid=rsn_boston_embed_off_domain_ots" width="624" height="351" frameborder="0" allow="autoplay" allowfullscreen=""></iframe>

<p><em><a href="https://www.nbcsports.com/boston/patriots/nfl-rookie-year-odds-can-mac-jones-pass-jamarr-chase?cid=Yahoo&amp;partner=ya4nbcs&amp;chrcontext=WCAU">NFL Rookie of the Year race: Can Mac Jones catch Ja'Marr Chase?</a> originally appeared on <a href="https://www.nbcsports.com/boston?cid=MSN&amp;chrcontext=WCAU">NBC Sports Boston</a></em></p>
<div class="mobile-app-promotion">
	
<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	<strong><em>Our redesigned local news and weather app is live! Download it for </em></strong><a href="https://apps.apple.com/us/app/nbc10-philadelphia-local-news/id331808522">iOS</a><em> or </em><a href="https://play.google.com/store/apps/details?id=com.nbcuni.nbcots.nbcphiladelphia.android&amp;hl=en_US&amp;gl=US">Android</a><em> </em><strong><em>— and sign up for alerts.</em></strong></blockquote>
</div>
</div>

<p>The NFL's youth movement was on full display Sunday.</p>

<p>In New England, Patriots rookie Mac Jones was one of just five quarterbacks to top 300 passing yards in the Patriots' 54-13 rout of the New York Jets. In Baltimore, Cincinnati Bengals first-year wide receiver Ja'Marr Chase exploded for&nbsp;<em>201&nbsp;</em>receiving yards to lead all pass-catchers -- just ahead of rookie tight end Kyle Pitts, who racked up 163 yards.</p>
<div class="recirc-module">
	<h3 class="recirc__heading">Sports</h3>
	<p class="recirc__subheading">In partnership with NBC Sports Philadelphia</p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Why Eagles Owner Jeff Lurie Can&#039;t Trust Howie Roseman With 2022 NFL Draft" href="https://www.nbcphiladelphia.com/news/sports/nbcsports/jeff-lurie-howie-roseman-trust-2022-nfl-draft/3015285/">
							<img class="post__image" srcset="https://media.nbcphiladelphia.com/2021/10/roseman_h_USATSI_17021324.jpg?quality=85&amp;strip=all&amp;resize=200%2C113 200w, https://media.nbcphiladelphia.com/2021/10/roseman_h_USATSI_17021324.jpg?quality=85&amp;strip=all&amp;resize=400%2C225 400w, https://media.nbcphiladelphia.com/2021/10/roseman_h_USATSI_17021324.jpg?quality=85&amp;strip=all&amp;resize=600%2C338 600w, " src="https://media.nbcphiladelphia.com/2021/10/roseman_h_USATSI_17021324.jpg?quality=85&#038;strip=all&#038;resize=600%2C338" alt="" sizes="200px" loading="lazy" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Philadelphia Eagles" class="post__tag" href="https://www.nbcphiladelphia.com/tag/philadelphia-eagles/">Philadelphia Eagles</a>
																			<span class="post__date post__date--has-category">
								26 mins ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Why Eagles Owner Jeff Lurie Can&#039;t Trust Howie Roseman With 2022 NFL Draft" class="post__title--link" href="https://www.nbcphiladelphia.com/news/sports/nbcsports/jeff-lurie-howie-roseman-trust-2022-nfl-draft/3015285/">
								Why Eagles Owner Jeff Lurie Can&#039;t Trust Howie Roseman With 2022 NFL Draft							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Beijing Says Strict ‘Closed Loop&#039; Will Be in Place for Winter Olympics Coronavirus Bubble" href="https://www.nbcphiladelphia.com/news/national-international/beijing-says-strict-closed-loop-will-be-in-place-for-winter-olympics-coronavirus-bubble/3016025/">
							<img class="post__image" srcset="https://media.nbcphiladelphia.com/2021/08/Webp.net-resizeimage20287429.jpg?quality=85&amp;strip=all&amp;resize=200%2C113 200w, https://media.nbcphiladelphia.com/2021/08/Webp.net-resizeimage20287429.jpg?quality=85&amp;strip=all&amp;resize=400%2C225 400w, https://media.nbcphiladelphia.com/2021/08/Webp.net-resizeimage20287429.jpg?quality=85&amp;strip=all&amp;resize=600%2C338 600w, " src="https://media.nbcphiladelphia.com/2021/08/Webp.net-resizeimage20287429.jpg?quality=85&#038;strip=all&#038;resize=600%2C338" alt="" sizes="200px" loading="lazy" />
						</a>

						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Winter Olympics" class="post__tag" href="https://www.nbcphiladelphia.com/tag/winter-olympics/">Winter Olympics</a>
																			<span class="post__date post__date--has-category">
								2 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Beijing Says Strict ‘Closed Loop&#039; Will Be in Place for Winter Olympics Coronavirus Bubble" class="post__title--link" href="https://www.nbcphiladelphia.com/news/national-international/beijing-says-strict-closed-loop-will-be-in-place-for-winter-olympics-coronavirus-bubble/3016025/">
								Beijing Says Strict ‘Closed Loop&#039; Will Be in Place for Winter Olympics Coronavirus Bubble							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<p>With seven weeks in the books, we have a big enough sample size to see which recent draft picks have the best shot at winning 2021 NFL Offensive Rookie of the Year.</p>

<p>Did Chase pull away from the pack Sunday with his career day? Is Jones in a better position to win the award over the course of 17 games? Which other rookies are in the running?</p>

<div class="embed-link embed-tw"><blockquote class="twitter-tweet"><p lang="en" dir="ltr" xml:lang="en">Who is the NFL Offensive Rookie of the Year through seven weeks?</p>— NBC Sports Boston (@NBCSBoston) <a href="https://twitter.com/NBCSBoston/status/1452703999778504709?ref_src=twsrc%5Etfw">October 25, 2021</a></blockquote></div>

<p>Below are the five favorites for Offensive Rookie of the Year, and our take on who will win the award after Week 18 of the 2021 NFL regular season. </p>

<h2>Ja'Marr Chase, WR, Cincinnati Bengals </h2>

<p><strong>Stats through Week 7: </strong>35 receptions, 754 yards, 6 TDs&nbsp;</p>

<p>Chase is the clear front-runner, and with good reason. He leads the NFL in yards per reception (21.5) and ranks second behind only Cooper Kupp in receiving yards. Simply put, he's been one of the league's best offensive players this season, period.</p>

<p>History isn't on Chase's side, however. Only three wide receivers have won Offensive Rookie of the Year in the last two decades, the most recent being Odell Beckham Jr., who needed to average 108.8 yards per game in 2014. Then again, Chase is at 107.7 yards per game right now.</p>

<h2>Mac Jones, QB, New England Patriots </h2>

<p><strong>Season stats:</strong> 174 for 247, 70.4% completion rate, 1779 yards, 8&nbsp;TD, 6&nbsp;INT, 92.8 passer rating</p>

<p>Jones is by far the best rookie QB in his class and ranks in the top 10 among all signal-callers in completion percentage (fourth) and total yards (ninth). He's coming off his first career 300-yard game and has thrown seven TD passes in his last four games.</p>

<h5><a href="https://www.nbcsports.com/boston/patriots/patriots-rookie-mac-jones-joins-exclusive-qb-group-after-outburst-vs-jets?int&amp;chrcontext=WCAU">Mac Jones joins exclusive group after career day vs. Jets</a></h5>

<p>Chase will be tough to catch if he keeps averaging 100 yards per game. But offensive coordinator Josh McDaniels has opened the playbook up for Jones, who isn't too far off 2020 Rookie of the Year Justin Herbert's pace of 4,336 passing yards last season.</p>

<p>While Jones may need to increase his touchdown rate to make this a stiffer competition, he'll be very much in the conversation if he flirts with 4,000 passing yards.</p>

<h2>Trevor Lawrence, QB, Jacksonville Jaguars </h2>

<p><strong>Season stats:</strong> 129 for 216, 59.7% completion rate, 1465 yards, 7 TD, 8 INT; 26 rushes, 121 yards, 2 TD; 75.5 passer rating (six games)</p>

<p>Lawrence has made do of a rough situation in Jacksonville, committing plenty of turnovers but also topping 300 passing yards twice with a mediocre supporting cast.</p>

<p>The No. 1 overall pick has plenty of ground to make up on Jones, but it's still possible the Jaguars abandon the run game and allow Lawrence to throw it 40-to-50 times per game. That said, it's hard to see Lawrence winning this award if Jacksonville finishes in the NFL basement.</p>

<h2>Najee Harris, RB, Pittsburgh Steelers </h2>

<p><strong>Season stats:</strong> 102 rushes, 388 yards, 2 TDs; 34 receptions, 244 yards, 2 TDs</p>

<p>Harris is Pittsburgh's undisputed workhorse: His 136&nbsp;total touches are 101 more (!) than the next-closest Steeler, Diontae Johnson. The Alabama product hasn't found much running room behind an inexperienced offensive line, but he's excelling as a receiver more receptions than every running back except Detroit's D'Andre Swift.</p>

<p>Alvin Kamara and Saquon Barkley won this award in back-to-back years in 2017 and 2018, so if Harris continues to see high volume, he could make a late push.</p>

<h2>Kyle Pitts, TE, Atlanta Falcons </h2>

<p><strong>Season stats:</strong> 31 receptions, 471 yards, 1 TD</p>

<p>After a relatively quiet start, Pitts is proving why the Falcons made him the highest-drafted tight end in NFL history. The former Florida Gator has 16 receptions and 282 yards in his last two games and <a href="https://twitter.com/FieldYates/status/1452608345039413253">has the most receiving yards</a> through his first six contests of any NFL tight end, ever.</p>

<p>A tight end has never won Offensive Rookie of the Year since the award's inception in 1967. Pitts seems like a long shot, but he probably has the best chance of any tight end in history to become the first.</p>

									</div>
							<div class="article-copyright">Copyright RSN</div>
				<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcphiladelphia.com/tag/nfl-rookie-of-the-year/">NFL Rookie of the Year</a><a class="article-tags__tag" href="https://www.nbcphiladelphia.com/tag/nfl/">nfl</a><a class="article-tags__tag" href="https://www.nbcphiladelphia.com/tag/new-england-patriots/">New England Patriots</a><a class="article-tags__tag" href="https://www.nbcphiladelphia.com/tag/mac-jones/">MAC Jones</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fnfl-rookie-of-the-year-2021-mac-jones-jamarr-chase%2F3015750%2F&#038;NFL%20Rookie%20of%20the%20Year%3A%20Can%20Mac%20Jones%20Overtake%20Ja%27Marr%20Chase%3F?_osource=db_npd_nbc_wcau_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=NFL%20Rookie%20of%20the%20Year%3A%20Can%20Mac%20Jones%20Overtake%20Ja%27Marr%20Chase%3F&#038;url=https%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fnfl-rookie-of-the-year-2021-mac-jones-jamarr-chase%2F3015750%2F?_osource=db_npd_nbc_wcau_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=NFL%20Rookie%20of%20the%20Year%3A%20Can%20Mac%20Jones%20Overtake%20Ja%27Marr%20Chase%3F%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcphiladelphia.com%2Fnews%2Fsports%2Fnfl-rookie-of-the-year-2021-mac-jones-jamarr-chase%2F3015750%2F?_osource=db_npd_nbc_wcau_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
						_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'text'
			});
					};
	</script>
			<div
			id="mobile-native-below-article"
			data-react-component="NativeSponsor"
			data-title="Native Sponsor"
			data-include-sponsored="true"
			data-beforetext="Presented By"
		>
		</div>
					</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="nbc_most_popular-2" class="widget widget_nbc_most_popular"><div class="nbc-most-popular" data-react-component="MostPopular" data-title="Trending Stories" data-include-sponsored="true" data-beforetext="Presented By"></div></section><section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_148" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_148', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Philadelphia, PA"></div>
	<a class="weather-module__conditions" href="https://www.nbcphiladelphia.com/weather/">
		<div data-react-component="IframeConditions" data-location="19101"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_572" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_572', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="ad_layers_ad_widget-9" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilemultibox_178" class=" gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_178', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script></section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-1861572874" class="module-civicScience" data-tgtid="67ed2dfc-f223-44f4-f9e9-6ebcf5490750"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_751" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_751', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_175" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_175', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_204" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_204', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcphiladelphia.com/" class="site-footer__logo">
					<img
						src="https://media.nbcphiladelphia.com/2021/04/Philadelphia@3x.png?fit=549%2C120&#038;quality=85&#038;strip=all"
						alt="NBC10 Philadelphia"
						loading="lazy"
					/>
				</a>
			
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="https://www.facebook.com/nbcphiladelphia" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbcphiladelphia" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbcphiladelphia" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2256341" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2256341"><a href="https://www.nbcphiladelphia.com/send-feedback/">Share a News Tip or Feedback</a></li>
<li id="menu-item-2242054" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2242054"><a href="/investigations/submit-tip/">Share a Tip for the NBC10 Investigators</a></li>
<li id="menu-item-2241580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2241580"><a href="https://www.nbcphiladelphia.com/newsletters/">Newsletters</a></li>
<li id="menu-item-2241590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2241590"><a href="https://www.nbcphiladelphia.com/contact-us/">Connect With Us</a></li>
<li id="menu-item-2260640" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2260640"><a href="https://comcastcentercampus.com/">About the Comcast Center Campus</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-1979913" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1979913"><a href="https://publicfiles.fcc.gov/tv-profile/wcau/">WCAU Public Inspection File</a></li>
<li id="menu-item-1979916" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1979916"><a href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_10_Philadelphia/">Privacy Policy</a></li>
<li id="menu-item-2223070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2223070"><a href="https://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC_10_Philadelphia/">Do Not Sell My Personal Information</a></li>
<li id="menu-item-1979950" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1979950"><a href="https://www.nbcphiladelphia.com/wcau-employment-information/">WCAU EMPLOYMENT INFORMATION</a></li>
<li id="menu-item-2578140" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2578140"><a href="https://www.nbcphiladelphia.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-1979951" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1979951"><a href="https://www.nbcphiladelphia.com/terms-of-service/">TERMS OF SERVICE</a></li>
<li id="menu-item-1979922" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1979922"><a href="mailto:WCAUViewerMail.Advertising@nbcuni.com?subject=Advertise%20with%20Us%20HP/">Advertise with us</a></li>
<li id="menu-item-1979952" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1979952"><a href="https://www.nbcphiladelphia.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-2475593" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2475593"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_10_Philadelphia">CA Notice</a></li>
<li id="menu-item-1979918" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1979918"><a href="https://info.evidon.com/pub_info/209?v=1&#038;nt=0&#038;nw=false/">AdChoices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2021 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

		<script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-document-language="true" type="text/javascript" charset="UTF-8" data-domain-script=""></script>			<script type="text/javascript">
	(function() {
		var _sf_async_config      = window._sf_async_config = window._sf_async_config || {};
		_sf_async_config.domain   = "nbcphiladelphia.com";
		_sf_async_config.uid      = 15527;
		_sf_async_config.sections = "sports";
		_sf_async_config.authors  = "Darren Hartwell";
		_sf_async_config.title    = "NFL Rookie of the Year: Can Mac Jones Overtake Ja'Marr Chase?";
		
		var e = document.createElement('script');
		var n = document.getElementsByTagName('script')[0];
		e.type = 'text/javascript';
		e.async = true;
		e.src = '//static.chartbeat.com/js/chartbeat.js';
		n.parentNode.insertBefore(e, n);
	})();
	</script>
			<!-- Begin comScore Tag -->
		<script>
		var usPrivacyCookie = new RegExp("usprivacy=([^;]+)").exec(document.cookie),
		usPrivacy = null !== usPrivacyCookie ? unescape(usPrivacyCookie[1]) : undefined,
		csUCFR= '1YNN' === usPrivacy ? '': '0',
		_comscore = _comscore || [];
		_comscore.push({
			c1: "2",
			c2: "6035083",
			cs_ucfr: csUCFR,
		});
		(function() {
			var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
			s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
			el.parentNode.insertBefore(s, el);
		})();
		</script>
		<noscript>
			<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
		(function() {
			window._taboola = window._taboola || [];
			window._newsroom = window._newsroom || [];
			var loaderUrl = 'https://cdn.taboola.com/libtrc/nbcots-network/loader.js';
			const taboola_config = {};

			taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '3015750' );
			taboola_config['url'] = document.URL;
			taboola_config['tracking'] = '_osource=taboola-recirc';
			_taboola.push(taboola_config);

			
			!function (e, f, u, i) {
				e.async = 1;
				e.src = u;
				e.id = i;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			loaderUrl,
			'tb_loader_script');

			!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0],
			"\/\/c2.taboola.com\/nr\/nbcots-wcau\/newsroom.js");
		}());
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcphiladelphia.com/news/sports/nfl-rookie-of-the-year-2021-mac-jones-jamarr-chase/3015750/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcphiladelphia.com/">
					<img
						src="https://media.nbcphiladelphia.com/2021/04/Philadelphia@3x.png?fit=549%2C120&#038;quality=85&#038;strip=all"
						alt="NBC10 Philadelphia"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcphiladelphia.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="Tokyo Olympics" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/tokyo-summer-olympics/">
					Tokyo Olympics				</a>
							<a data-lid="U.S. and World" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/national-international/">
					U.S. and World				</a>
							<a data-lid="NBCLX" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a data-lid="Politics" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/politics/">
					Politics				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/weather/">
					Weather				</a>
							<a data-lid="Weather Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a data-lid="School Closings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/school-closings/">
					School Closings				</a>
							<a data-lid="See It, Share It" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.nbcphiladelphia.com/ugc/">
					See It, Share It				</a>
							<a data-lid="Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a data-lid="Phillies" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/phillies/">
					Phillies				</a>
							<a data-lid="Eagles" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/eagles/">
					Eagles				</a>
							<a data-lid="Sixers" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/sixers/">
					Sixers				</a>
							<a data-lid="Flyers" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/flyers/">
					Flyers				</a>
							<a data-lid="NBC Sports Philadelphia" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcsports.com/philadelphia">
					NBC Sports Philadelphia				</a>
							<a data-lid="Investigators" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/investigators/">
					Investigators				</a>
							<a data-lid="NBC10 Responds" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/investigators/consumer/">
					NBC10 Responds				</a>
							<a data-lid="Watch The Lineup" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/the-lineup/">
					Watch The Lineup				</a>
							<a data-lid="Entertainment" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/">
					Entertainment				</a>
							<a data-lid="Philly Live" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/entertainment/philly-live/">
					Philly Live				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="Share a News Tip or Feedback" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcphiladelphia.com/send-feedback/">
					Share a News Tip or Feedback				</a>
							<a data-lid="Share a Consumer Complaint" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/consumer-form/">
					Share a Consumer Complaint				</a>
							<a data-lid="Share Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcphiladelphia.com/ugc/">
					Share Photos and Video				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcphiladelphia.com/newsletters/">
					Newsletters				</a>
							<a data-lid="Cozi TV" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://cozitv.com/">
					Cozi TV				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="https://www.facebook.com/nbcphiladelphia" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbcphiladelphia" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbcphiladelphia" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us"
	>
	Contact Us</a>
<link rel='stylesheet' id='all-css-0' href='https://www.nbcphiladelphia.com/_static/??-eJydjksOgyAYhC9UeQgiLJreoOkNGviBSMLDCLbx9lVP0HY1i5n5ZvB77qDk5nLDbXLJVZwNdLXpFkrGEMPhmDVEi6FWnEptjzKvUS+oJ06PXvlRcempZL2UHKWQ0R684B/BvpTmFmQt84ZzEAOAkFpRYez/zLiVtd31CzmjqBEARHM2EOnIvvAt9lQ4gXPUm1ueNe1np6N7S1cq2EDHXhL5AQ2fdXI=' type='text/css' media='all' />
<script src='https://www.nbcphiladelphia.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/i18n.min.js?ver=4ab02c8fd541b8cfb8952fe260d21f16' id='wp-i18n-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.21' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/url.min.js?ver=d80b474ffb72c3b6933165cc1b3419f6' id='wp-url-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/hooks.min.js?ver=63769290dead574c40a54748f22ada71' id='wp-hooks-js'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/dist/api-fetch.min.js?ver=0bb73d10eeea78a4d642cdd686ca7f59' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/common.fcc9123f27fb3d49cde8.bundle.min.js?ver=1.0.2' id='nbc-common-js-js'></script>
<script async src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.87a2ab5dafb347c6e53b.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script async src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/global.bf7b5a0b45df529f8361.bundle.min.js?ver=1.0.2' id='nbc-global-js-js'></script>
<script async src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/article.53b0ab3116d636de915e.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/analytics.9ba537a09f8b0b5ceac2.bundle.min.js?ver=1.0.2' id='nbc-analytics-js-js'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/static/js/zepto.min.js?ver=1.0.2' id='zepto-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/static/js/player.6.1.3.js?ver=1.0.2' id='pdk-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.7b5017f07999a106edc4.bundle.min.js?ver=1.0.2' id='nbc-video-player-js'></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.6' id='sharethrough-js'></script>
<script async src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/nativeSponsor.fbecc9b3c34c4c72b2c5.bundle.min.js?ver=1.0.2' id='nbc-native-sponsor-js'></script>
<script async src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/flyoutNav.276edabb7c307347f121.bundle.min.js?ver=1.0.2' id='nbc-flyout-nav-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/articleContent.002368ae3a0d6363e579.bundle.min.js?ver=1.0.2' id='nbc-article-content-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/185796-256714881512110.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-includes/js/wp-embed.min.js?ver=5.5.6' id='wp-embed-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/mostPopular.24581aafd2c2eedb4e36.bundle.min.js?ver=1.0.2' id='nbc-most-popular-js'></script>
<script src='https://www.nbcphiladelphia.com/wp-content/themes/nbc-station/client/build/js/civicScience.4db1dfb9fe92d553e9e3.bundle.min.js?ver=1.0.2' id='civic-science-js'></script>
<script id='wp-parsely-api-js-extra'>
var wpParsely = {"apikey":"nbcphiladelphia.com"};
</script>
<script data-cfasync="false" src='https://www.nbcphiladelphia.com/wp-content/mu-plugins/wp-parsely-2.6/build/init-api.js?ver=2.6.1' id='wp-parsely-api-js'></script>
<script data-cfasync="false" data-parsely-site="nbcphiladelphia.com" src='https://cdn.parsely.com/keys/nbcphiladelphia.com/p.js?ver=2.6.1' id="parsely-cfg"></script>
<script src='https://stats.wp.com/e-202143.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'165596172',post:'3015750',tz:'-4',srv:'www.nbcphiladelphia.com'} ]);
	_stq.push([ 'clickTrackerInit', '165596172', '3015750' ]);
</script>

</body>
</html>
