    
    
    
    
    
    
    
    
    
    
    
    
    
    
    

            
                        



	

  


            
  
    
  
                                        
  
   
  
             
          
                                                   
                                                                                         
      
                                                                                                                                                                                                                                                                                                                                                            
                                         
                                                                                                                                        
     
     
          
             
                             
        
                         
                                
                                                
                               
      
   
   
    
        
    
  
  
  
    
  
  
  
        
  
          
    
      
      
      
              
              
        
  

  
                                                     
            
                          
	
                                      
<!DOCTYPE html><html lang="en"><head prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#"><meta name="viewport" content="width=1140, user-scalable=yes"><meta http-equiv="content-type" content="text/html; charset=UTF-8"><meta http-equiv="imagetoolbar" content="false"><meta property="fb:app_id" content="196375740321" /><meta property="og:url" content="//www.nbcphiladelphia.com/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html"/><meta property="og:type" content="video" /><meta property="og:video" content="http://www.nbcphiladelphia.com/pdk442/pdk/swf/flvPlayer.swf?v=http%3A%2F%2Fwww.nbcphiladelphia.com%2Fi%2Fembed_social%2F%3Fcid%3D510992842%26path%3D%2Fnews%2Fsports%2Fcsn%2Fphillies" /><meta property="og:video:width" content="375" /><meta property="og:video:height" content="290" /><meta property="og:video:type" content="application/x-shockwave-flash" /><meta property="og:image" content="https://media.nbcphiladelphia.com/images/1200*675/David+Montgomery+Still.jpg" /><meta property="og:title" content="Friday with the Phillies: Legacy of David Montgomery Lives On" /><meta property="og:description" content="David Montgomery&rsquo;s legacy lives on throughout Philadelphia: his alma mater, Penn Charter, in South Philadelphia where he got one of the Major Leagues' best ballparks built, and a ballfield named in his honor in his native Roxborough." /><meta property="og:site_name" content="NBC 10 Philadelphia" /><link rel="image_src" href="https://media.nbcphiladelphia.com/images/1200*675/David+Montgomery+Still.jpg" /><meta property="fb:pages"content="96623207231"><meta property="fb:pages"content="296562883986"><meta name="tp:preferredRuntimes" content="Universal,HTML5" /><meta name="tp:preferredFormats" content="m3u,mpeg4,webm,ogg,flv,F4M"><meta name="keywords" content=""><link rel="shortcut icon" href="https://media.nbcphiladelphia.com/designimages/favicon-phi.ico"><script type="text/javascript">
var win7ie = navigator.userAgent.indexOf('Windows NT 6.1') > -1 && (navigator.userAgent.indexOf('Trident') > -1 || navigator.userAgent.indexOf('MSIE') > -1);
if(win7ie) {
    var allMetaElements = document.getElementsByTagName('meta');
    for (var i=0; i<allMetaElements.length; i++) {
      if (allMetaElements[i].getAttribute("name") == "tp:preferredRuntimes") {
         allMetaElements[i].setAttribute('content', "Flash,HTML5");
         break;
      }
    }
}
// Stop older versions of IE from choking on calls to the console.
if(typeof console == "undefined") {

    console = {};
    console.log = function(msg) {
    // fail silently
    }

    console.warn = function(msg) {
    // fail silently
    }

    console.error = function(msg) {
    // fail silently
    }

    console.info = function(msg) {
    // fail silently
    }

}
</script><script type="text/javascript">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</script><script src="//www.nbcphiladelphia.com/includes/ads.js?r=-537853966" type="text/javascript"></script><!-- Facebook Pixel Code --><script>
    !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
    n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
    document,'script','//connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1655305654750814');
    fbq('track', "ViewContent");
    fbq('track', 'PageView');
        </script><noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=1655305654750814&ev=PageView&noscript=1"
    /></noscript><!-- End Facebook Pixel Code --><script>
  var activateSharethrough = false;
  var shareThroughDesktopKey;
  var shareThroughMobileKey;
  </script><script>
  var directSoldStyles = true;
  </script><script>
var fakeLoadMore = true;
</script><title>Friday with the Phillies: Legacy of David Montgomery Lives On  - NBC 10 Philadelphia</title><link rel="amphtml" href="https://www.nbcphiladelphia.com/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html?amp=y"><link rel="canonical" href="https://www.nbcphiladelphia.com/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html" /><meta name="sailthru.type" content="video" /><meta name="sailthru.description" content="David Montgomery&amp;rsquo;s legacy lives on throughout Philadelphia: his alma mater, Penn Charter, in South Philadelphia where he got one of the Major Leagues' best ballparks built, and a ballfield named in his honor in his native Roxborough." /><meta name="description" content="David Montgomery&amp;rsquo;s legacy lives on throughout Philadelphia: his alma mater, Penn Charter, in South Philadelphia where he got one of the Major Leagues' best ballparks built, and a ballfield named in his honor in his native Roxborough." /><meta name="sailthru.tags" content="david montgomery, phillies, philadelphia, philly" /><meta name="keywords" content="david montgomery, phillies, philadelphia, philly" /><meta name="news_keywords" content="david montgomery, phillies, philadelphia, philly" /><meta itemprop="keywords" content="david montgomery, phillies, philadelphia, philly"/><meta name="sailthru.title" content="Friday with the Phillies: Legacy of David Montgomery Lives On" /><meta name="title" content="Friday with the Phillies: Legacy of David Montgomery Lives On" /><meta property="title" content="Friday with the Phillies: Legacy of David Montgomery Lives On"/><link rel="image_src" href="https://media.nbcphiladelphia.com/images/133*75/David+Montgomery+Still.jpg" /><meta itemprop="image" content="https://media.nbcphiladelphia.com/images/133*75/David+Montgomery+Still.jpg"/><meta name="sailthru.date" content="2019-06-07 19:19:26" /><link rel="stylesheet" href="//www.nbcphiladelphia.com/templates/nbc_global_styles.css?r=-1014484923" type="text/css" /><script type="text/javascript">
    var thisIsAGalleryPage = false;
  </script><script src="//www.nbcphiladelphia.com/includes/third_party_plugins.js?r=1806176154" type="text/javascript"></script><script>
    var __mpsPlatform = "desktop";
        var mpscall = {
      "site"            : "local-web",
      "type"            : "Video Release",
      "content_id"      : "510992842",
      "cag[station]"    : "OTS",
      "cag[callLetter]" : "WCAU",
      "cag[feature]"    : "",
      "cag[region]"     : "Philadelphia",
      "cag[sensitive]"  : "false",
      "field[source]"   : nbc.referrer,
            "cag[tags]"       : "",
      "cag[platform]"   : __mpsPlatform,
              "cag[stationtype]": "nbc"
          }
    var mpsopts = {
      "host":"mps.nbcuni.com",
      "updatecorrelator":true
    }
    var mps=mps||{};mps._ext=mps._ext||{};mps._adsheld=[];mps._queue=mps._queue||{};mps._queue.mpsloaded=mps._queue.mpsloaded||[];mps._queue.mpsinit=mps._queue.mpsinit||[];mps._queue.gptloaded=mps._queue.gptloaded||[];mps._queue.adload=mps._queue.adload||[];mps._queue.adclone=mps._queue.adclone||[];mps._queue.adview=mps._queue.adview||[];mps._queue.refreshads=mps._queue.refreshads||[];mps.__timer=Date.now();mps.__intcode="v2";if(typeof mps.getAd!="function")mps.getAd=function(adunit){if(typeof adunit!="string")return false;var slotid="mps-getad-"+adunit.replace(/\W/g,"");if(!mps._ext||!mps._ext.loaded){mps._queue.gptloaded.push(function(){typeof mps._gptfirst=="function"&&mps._gptfirst(adunit,slotid);mps.insertAd("#"+slotid,adunit)});mps._adsheld.push(adunit)}return'<div id="'+slotid+'" class="mps-wrapper" data-mps-fill-slot="'+adunit+'"></div>'};(function(){head=document.head||document.getElementsByTagName("head")[0],mpsload=document.createElement("script");mpsload.src="//"+mpsopts.host+"/fetch/ext/load-"+mpscall.site+".js?nowrite=2";mpsload.id="mps-load";head.insertBefore(mpsload,head.firstChild)})();
  </script><script type="text/javascript">
    // mmModule is now deprecated, do not add to object.
    mmModule = {}
    mmModule.omni = "nbcuotsdivisiontotal,nbcuotsphiladelphiatotal";
    nbc.omniture.suite = "nbcuotsdivisiontotal,nbcuotsphiladelphiatotal";
  </script><script language="JavaScript">
                  s_linkInternalFilters="javascript:,nbcphiladelphia.com,media.nbcphiladelphia.com,events.nbcphiladelphia.com,tsn.nbcphiladelphia.com,autos.nbcphiladelphia.com";
var nbcu_account="nbcuotsdivisiontotal,nbcuotsphiladelphiatotal";
var nbcu_prop8 ="nbc";
var nbcu_prop9 ="PHI";
var nbcu_prop10 ="WCAU";        nbc.callLetters = "WCAU";
    nbc.contentType = "";
  </script><script src="//www.nbcphiladelphia.com/includes/VisitorAPI.js?r=-1098718195" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/ots_dil.js?r=-1331500469" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/AppMeasurement.js?r=-2106134047" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/nbc_global_common.js?r=-748994356" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/nbc_common_init.js?r=1680398388" type="text/javascript"></script><script type='text/javascript'>
		(function() {
		    if(typeof window['win7ie'] !== "undefined") {
		        var pdkScript = (window['win7ie']) ? "//www.nbcphiladelphia.com/assets/pdk587/pdk/tpPdk.js" : "/includes/pdk6.js";document.write('<scr'+'ipt type="text/javascript" src="' + pdkScript + '"></sc'+'ript>');
		    } else {document.write('<scr'+'ipt type="text/javascript" src="/includes/pdk6.js"></sc'+'ript>');}
		})();
	  </script><link rel="stylesheet" href="//www.nbcphiladelphia.com/templates/pdk6_smooth.css?r=-1974201622" type="text/css" /><script type="text/javascript">
      var nbcVideoPageUtils = nbcVideoPageUtils || {};
      var nbcVPUTools = nbcVPUTools || new nbc.tools('nbcVPUTools');
    </script><script src="//www.nbcphiladelphia.com/includes/nbc_global_pws.js?r=-2024343032" type="text/javascript"></script><script>
    randomValue = "&rndm=" + Math.random()*10000000000000000;
    if ((U.readCookie("zipCode") && U.readCookie("zipCode") !== "") || U.readCookie("pwsSetDefault") !== null ) {
      if(U.readCookie("pwsSetDefault") !== null) {
        weatherZipCode = JSON.parse(U.readCookie("pwsSetDefault")).zip;
      } else {
        weatherZipCode =  U.readCookie("zipCode");
      }
      var marketZipCode = "19101"
          } else {
      weatherZipCode = "19101";
    }
    nbc.gptParams.pageData.zipcode = (readCookie("adZipCode")) ? readCookie("adZipCode") : weatherZipCode;
    nbc.weather= {
      validatedZip: "",
      adZipCode: weatherZipCode
    };

    var showLeaderboardAd = true;
  </script><script type="text/javascript">
    //<![CDATA[
    var videoAdContentGroup = "${videoAdContentGroup}";
    var videoadSiteKey =  "phi";
    var partnerID = "1748351";
    var nbcfacebook = {
      connected: "no"
    };
                                        var _sf_startpt=(new Date()).getTime()
    // random number for ads
    var randDARTNumber=0;
    function genSetRandDARTNumber() {
      randDARTNumber = Math.round(Math.random()*1000000000000);
    }
    genSetRandDARTNumber();
    //]]></script><script type="text/javascript">
    // Get Cookie Value
    function getPartnerCookieValue (cookieName) {
       var exp = new RegExp (escape(cookieName) + "=([^;]+)");
       if(exp.test (document.cookie + ";")) {
          exp.exec (document.cookie + ";");
          return unescape(RegExp.$1);
       }
    }
    // Write Cookie
    function writePartnerCookie (CookieName, CookieValue, periodType, offset) {
       var expireDate = new Date ();
       offset = offset / 1;
       var myPeriodType = periodType;
       switch (myPeriodType.toLowerCase()) {
          case "years":
             var year = expireDate.getYear();
             // Note some browsers give only the years since 1900, and some since 0.
             if (year < 1000) year = year + 1900;
             expireDate.setYear(year + offset);
          break;
          case "months":
             expireDate.setMonth(expireDate.getMonth() + offset);
          break;
          case "days":
             expireDate.setDate(expireDate.getDate() + offset);
          break;
          case "hours":
             expireDate.setHours(expireDate.getHours() + offset);
          break;
          case "minutes":
             expireDate.setMinutes(expireDate.getMinutes() + offset);
          break;
          default:
             // alert ("Invalid periodType parameter for writePartnerCookie()");
          break;
       }
       try{
          document.cookie = escape(CookieName ) + "=" + escape(CookieValue) + "; expires=" + expireDate.toGMTString() + "; path=/";
                 }catch(e){
                 }
       try{
          document.cookie = "partnerSessionCookie=xfinity; path=/";
                 }catch(ee){
                 }
    }
    </script><script type="text/javascript">
        function checkPartnerCookie () {
          if(getPartnerCookieValue("partnerCookie")=="xfinity" && getPartnerCookieValue("partnerSessionCookie")=="xfinity"){
            document.write('<scr'+'ipt src="//secure.xfinity.com/shared/js-api/polaris_vendor_iframes.js?signin=false&profile=nbc&ft=true&id=xfinityNavBar&locale=en"></scr'+'ipt>');// new header (includes footer)
            $(document).ready(function(){
              $('body').addClass('xfinity');
            });
            xfinityOmniValue = "xfinity";// referenced in nbc_tracking_revamped
          }
        }
       var xfinityOmniValue = "";
        checkPartnerCookie();
       </script><script type="text/javascript">
    var disableDownloadApp = false;
      </script><script type="text/javascript">
        window._taboola = window._taboola || [];
                  _taboola.push({video:'510992842', tracking:'_osource=taboola-recirc'});
                !function (e, f, u) {
          e.async = 1;
          e.src = u;
          f.parentNode.insertBefore(e, f);
        }(document.createElement('script'),
        document.getElementsByTagName('script')[0],
        '//cdn.taboola.com/libtrc/nbcots-network/loader.js');
      </script><script>
      window._newsroom = window._newsroom || [];
            !function (e, f, u) {
        e.async = 1;
        e.src = u;
        f.parentNode.insertBefore(e, f);
      }(document.createElement('script'),
      document.getElementsByTagName('script')[0], '//c2.taboola.com/nr/nbcots-wcau/newsroom.js');
    </script><script>
targetPageParams = function() {
    return [
        "pageType=video",
        "callLetters=WCAU",
                    "articleLead=none"
            ]
};
</script><script src="//www.nbcphiladelphia.com/includes/at.js?r=546977887" type="text/javascript"></script><script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script><script>Sailthru.init({ customerId: '757cc89c051f4552fa5708e6f3b93a01' });</script><script async src="//js-sec.indexww.com/ht/p/186439-186231565045987.js"></script><link rel="alternate" type="application/json+oembed"
    href="https://www.nbcnewyork.com/services/oembed/?url=https://www.nbcphiladelphia.com/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html"
    title="Friday with the Phillies: Legacy of David Montgomery Lives On - NBC 10 Philadelphia " /></head><body id="video" class="video-phi  phi news csn  nbc "><div id="adTransitionalContainer"></div><script type="text/javascript">
    //must have for commenting
    var nbcfacebook = {
      connected: "no"
    };
  </script><script>
      function callTransitional() {
        window.location.href = nbc.fullDomain + '/transitional_ad/transitional_ad.html';
      }
    </script><div class="site-header-wrapper"><div class="site-header"><!-- navbarClass: nav-landing --><div class="navbar nav-landing"><div class="navbar-container"><div class="row"><div class="col--2"><div class="brand"><a target="_parent" href="/" name="&lpos=section navigation&lid=logo" data-lpos="section navigation" data-lid="logo"><img src="//media.nbcmiami.com/designimages/logo_philly_2x.png" alt="logo_philly_2x" /></a></div></div><div class="col--14"><ul class="nav-sections"><li class="nav-section Home"><a target="_parent" class="nav-section-title " href="/" alt="Home" lid=Home" data-lid="Home">Home</a></li><li class="nav-section News"><a target="_parent" class="nav-section-title nav-selected" href="/news" alt="News" lid=News" data-lid="News">News</a><div class="subnav-large-container"><div class="subnav-section-landing"><ul><li><a target="_parent" href="/news/local/" alt="Local"  data-lpos="subsection navigation" data-lid="Local">Local</a></li><li><a target="_parent" href="/news/politics/" alt="Politics"  data-lpos="subsection navigation" data-lid="Politics">Politics</a></li><li><a target="_parent" href="/news/national-international/" alt="U.S. & World"  data-lpos="subsection navigation" data-lid="U.S. & World">U.S. & World</a></li><li><a target="_parent" href="/news/sports/" alt="Sports"  data-lpos="subsection navigation" data-lid="Sports">Sports</a></li><li><a target="_parent" href="/news/sports/Philadelphia-Phillies-453010213.html" alt="Phillies"  data-lpos="subsection navigation" data-lid="Phillies">Phillies</a></li><li><a target="_parent" href="/news/sports/Philadelphia-Eagles-443033743.html" alt="Eagles"  data-lpos="subsection navigation" data-lid="Eagles">Eagles</a></li><li><a target="_parent" href="/news/sports/Philadelphia-76ers-453012353.html" alt="Sixers"  data-lpos="subsection navigation" data-lid="Sixers">Sixers</a></li><li><a target="_parent" href="/news/health" alt="Health"  data-lpos="subsection navigation" data-lid="Health">Health</a></li><li><a target="_parent" href="https://www.nbcphiladelphia.com/news/local/PHI-Wednesdays-Child-236075691.html?page=1" alt="Wednesday's Child"  data-lpos="subsection navigation" data-lid="Wednesday's Child">Wednesday's Child</a></li><li><a target="_parent" href="/news/weird/" alt="Weird"  data-lpos="subsection navigation" data-lid="Weird">Weird</a></li><li><a target="_parent" href="http://www.nbcphiladelphia.com/news/business/NBC10GrowingGreaterPhiladelphia-417042043.html" alt="Growing Greater Philadelphia"  data-lpos="subsection navigation" data-lid="Growing Greater Philadelphia">Growing Greater Philadelphia</a></li></ul></div></div></li><li class="nav-section Weather"><a target="_parent" class="nav-section-title " href="/weather" alt="Weather" lid=Weather" data-lid="Weather">Weather</a><div class="nav-section-subnav"><ul><li><a target="_parent" href="/weather/" alt="Forecast"data-lpos="subsection hover" data-lid="Forecast">Forecast</a></li><li><a target="_blank" href="http://www.nbcphiladelphia.com/weather/stories/PHI-Severe-Weather-Central-224616871.html" alt="Severe Weather Central"data-lpos="subsection hover" data-lid="Severe Weather Central">Severe Weather Central</a></li><li><a target="_parent" href="/weather/school-closings" alt="School Closing Alerts"data-lpos="subsection hover" data-lid="School Closing Alerts">School Closing Alerts</a></li><li><a target="_parent" href="/weather/maps/" alt="Maps & Radar"data-lpos="subsection hover" data-lid="Maps & Radar">Maps & Radar</a></li><li><a target="_parent" href="/weather/stories/" alt="Weather Stories"data-lpos="subsection hover" data-lid="Weather Stories">Weather Stories</a></li><li><a target="_parent" href="/weather/severe-weather-alerts" alt="Weather Alerts"data-lpos="subsection hover" data-lid="Weather Alerts">Weather Alerts</a></li></ul></div></li><li class="nav-section Entertainment"><a target="_parent" class="nav-section-title " href="/entertainment" alt="Entertainment" lid=Entertainment" data-lid="Entertainment">Entertainment</a><div class="nav-section-subnav"><ul><li><a target="_parent" href="/entertainment/entertainment-news" alt="Entertainment News"data-lpos="subsection hover" data-lid="Entertainment News">Entertainment News</a></li><li><a target="_parent" href="/entertainment/entertainment-news/Late-Night-on-NBC-Fallon-Meyers-Tonight-Show-250339161.html" alt="Late Night Recap"data-lpos="subsection hover" data-lid="Late Night Recap">Late Night Recap</a></li><li><a target="_parent" href="/blogs/open-house/" alt="Open House"data-lpos="subsection hover" data-lid="Open House">Open House</a></li><li><a target="_parent" href="/on-air/shows/1st-Look-LXTV-Best-in-Food-Nightlife-Travel-167601135.html" alt="1st Look"data-lpos="subsection hover" data-lid="1st Look">1st Look</a></li><li><a target="_parent" href="http://www.cozitv.com/" alt="COZI TV"data-lpos="subsection hover" data-lid="COZI TV">COZI TV</a></li><li><a target="_parent" href="http://www.talkstooptv.com/" alt="Talk Stoop"data-lpos="subsection hover" data-lid="Talk Stoop">Talk Stoop</a></li></ul></div></li><li class="nav-section Investigators"><a target="_parent" class="nav-section-title " href="/investigations" alt="Investigators" lid=Investigators" data-lid="Investigators">Investigators</a><div class="nav-section-subnav"><ul><li><a target="_parent" href="http://www.nbcphiladelphia.com/investigations" alt="NBC10 Investigators"data-lpos="subsection hover" data-lid="NBC10 Investigators">NBC10 Investigators</a></li><li><a target="_parent" href="http://www.nbcphiladelphia.com/investigations/NBC10-Responds-376402961.html" alt="NBC10 Responds"data-lpos="subsection hover" data-lid="NBC10 Responds">NBC10 Responds</a></li><li><a target="_parent" href="http://www.nbcphiladelphia.com/consumer-form/" alt="How to Submit to NBC10 Responds"data-lpos="subsection hover" data-lid="How to Submit to NBC10 Responds">How to Submit to NBC10 Responds</a></li></ul></div></li><li class="nav-section nav-more"><a target="_parent" class="nav-section-title" href="" name="&lpos=ellipsis hover&lid=ellipsis" data-lpos="ellipsis hover" data-lid="ellipsis"><div class="more-dropdown"></div></a><div class="nav-section-subnav"><ul><li><a target="_parent" href="/traffic" alt="Traffic" name="&lpos=ellipsis hover&lid=Traffic" data-lpos="ellipsis hover" data-lid="Traffic">Traffic</a></li><li><a target="_parent" href="/contact-us/" alt="Contact Us" name="&lpos=ellipsis hover&lid=Contact Us" data-lpos="ellipsis hover" data-lid="Contact Us">Contact Us</a></li><li><a target="_parent" href="/on-air/contests/" alt="Contests" name="&lpos=ellipsis hover&lid=Contests" data-lpos="ellipsis hover" data-lid="Contests">Contests</a></li><li><a target="_parent" href="https://sjobs.brassring.com/tgwebhost/searchresults.aspx?PartnerId=25354&SiteId=5108&Function=LinkQuery&LinkId=3385146" alt="Jobs at NBC10" name="&lpos=ellipsis hover&lid=Jobs at NBC10" data-lpos="ellipsis hover" data-lid="Jobs at NBC10">Jobs at NBC10</a></li><li><a target="_parent" href="http://www.nbcphiladelphia.com/contact-us/tv-listings" alt="TV Listings" name="&lpos=ellipsis hover&lid=TV Listings" data-lpos="ellipsis hover" data-lid="TV Listings">TV Listings</a></li></ul></div></li></ul></div><div class="col--8"><ul class="nav-small"><li class="nav-small-section nav-live-tv"><a target="_parent" href="/live" alt="Watch Live TV" class="nav-small-item" name="&lpos=Navigation - Watch Live TV&lid=Watch Live TV" data-lpos="Navigation - Watch Live TV" data-lid="Watch Live TV"><div class="watch-live-logo"></div><span class="livetv">LIVE TV</span></a><ul class="nav-small-sub"><li class="livetv">LIVE TV</li><li class="onnow">ON NOW</li><li><a target="_blank" href="/live" alt="MLB Baseball" name="&lpos=Navigation - Watch Live TV&lid=MLB Baseball" data-lpos="Navigation - Watch Live TV" data-lid="MLB Baseball"><div class="watch-live-key"></div><div id="liveTVE" class="watch-live-title">MLB Baseball</div><div class="play-grey-small"></div></a></li><li class="ondemand">ON DEMAND</li><li><a target="_blank" href="https://www.nbc.com/video" alt="NBC on Demand" name="&lpos=Navigation - Watch Live TV&lid=NBC on Demand" data-lpos="Navigation - Watch Live TV" data-lid="NBC on Demand"><div class="watch-live-key"></div><div class="watch-live-title">NBC on Demand</div><span class="desc">Watch the latest full episodes of your favorite NBC series anytime and anywhere.</span><div class="play-grey-small arrow"></div></a></li><li class="schedule"><a href="/contact-us/tv-listings/" alt="NBC on Demand" name="&lpos=Navigation - Watch Live TV&lid=Click for full schedule" data-lpos="Navigation - Watch Live TV" data-lid="Click for full schedule">Click for full schedule</a></li></ul></li><li><div class="nav-border"></div></li><li class="nav-small-section nav-weather"><a target="_parent" href="/weather" alt="weather" class="nav-small-item" name="&lpos=section navigation&lid=weather bug" data-lpos="section navigation" data-lid="weather bug"><div class="nav-weather-condition"><div class="nav-weather-icon"><img src="//media.nbcphiladelphia.com/designimages/ots_light_wx_103.png" alt="Overcast" /></div><div class="nav-weather-temp">77&deg;</div></div></a></li><li><div class="nav-border"></div></li><li class="nav-small-section nav-connect"><a target="_parent" href="" class="nav-small-item"><div>Connect</div></a><div class="subnav-large-container"><div class="nav-connect-sub"><div class="connect-media"><div class="connect-social"><div class="connect-social-icons"><a target="_parent" href="https://www.twitter.com/nbcphiladelphia" alt="Twitter" target="_blank" name="&lpos=Navigation - Connect&lid=Twitter" data-lpos="Navigation - Connect" data-lid="Twitter"><i class="fa fa-twitter"></i></a></div><div class="connect-social-icons"><a target="_parent" href="https://www.instagram.com/nbcphiladelphia/" alt="Instagram" target="_blank" name="&lpos=Navigation - Connect&lid=Instagram" data-lpos="Navigation - Connect" data-lid="Instagram"><i class="fa fa-instagram"></i></a></div><div class="connect-social-icons"><a target="_parent" href="https://www.facebook.com/nbcphiladelphia" alt="Facebook" target="_blank" name="&lpos=Navigation - Connect&lid=Facebook" data-lpos="Navigation - Connect" data-lid="Facebook"><i class="fa fa fa-facebook-official" aria-hidden="true"></i></a></div><div class="connect-subnav-title">Social Media</div></div><div class="connect-apps"><a target="_parent" href="/products" alt="products" name="&lpos=Navigation - Connect&lid=Mobile" data-lpos="Navigation - Connect" data-lid="Products"><div class="connect-apps-icon"><div class="connect-mobile"></div></div><div class="connect-subnav-title">Our Products</div></a></div><div class="connect-email"><a target="_parent" href="/newsletters" alt="newsletters" name="&lpos=Navigation - Connect&lid=Newsletters" data-lpos="Navigation - Connect" data-lid="Newsletters"><div class="connect-email-icon"><div class="connect-newsletter"></div></div><div class="connect-subnav-title">Newsletters</div></a></div><div class="connect-ugc"><a target="_parent" href="/ugc" alt="ugc" name="&lpos=Navigation - Connect&lid=UGC" data-lpos="Navigation - Connect" data-lid="UGC"><div class="connect-ugc-icon"><i class="fa fa-camera"></i></div><div class="connect-subnav-title">
                                                  See It, Share It
                                              </div></a></div><div class="connect-send"><a target="_blank" href="mailto:tips@nbcphiladelphia.com?body=Thanks%20for%20contacting%20NBC 10 Philadelphia.%20Please%20use%20this%20e-mail%20to%20send%20us%20news%20tips.%20Be%20sure%20to%20include%20a%20phone%20number,%20so%20we%20can%20contact%20you%20quickly,%20if%20necessary.%20If%20your%20tip%20is%20urgent,%20call%20%20our%20news%20desk%20at%20610-668-5510." alt="submit tips" name="&lpos=Navigation - Connect&lid=Submit Tips" data-lpos="Navigation - Connect" data-lid="Submit Tips"><div class="connect-apps-icon"><div class="connect-tips"></div></div><div class="connect-subnav-title">Send Tips</div></a></div></div><div class="connect-responds"><a target="_parent" href="/consumer-form" name="&lpos=Navigation - Connect&lid=consumer-form" data-lpos="Navigation - Connect" data-lid="consumer-form"><div class="connect-subnav-title"><img src="//media.nbcmiami.com/designimages/NBC_OTS_CONSUMER_PHILLY.png" alt="NBC_OTS_CONSUMER_PHILLY"></div><div class="connect-subnav-title">
                        Submit a Complaint
                      </div></a></div></div><div class="nav-connect-footer"><ul><li class="submit-tips"><a target="_parent" href="mailto:tips@nbcphiladelphia.com?body=Thanks%20for%20contacting%20NBC 10 Philadelphia.%20Please%20use%20this%20e-mail%20to%20send%20us%20news%20tips.%20Be%20sure%20to%20include%20a%20phone%20number,%20so%20we%20can%20contact%20you%20quickly,%20if%20necessary.%20If%20your%20tip%20is%20urgent,%20call%20%20our%20news%20desk%20at%20610-668-5510." alt="submit tips" name="&lpos=Navigation - Connect&lid=Submit Tips" data-lpos="Navigation - Connect" data-lid="Submit Tips">Submit Tips</a></li><li class="send-feedback"><a target="_parent" href="/send-feedback" alt="send feedback" name="&lpos=Navigation - Connect&lid=Send Feedback" data-lpos="Navigation - Connect" data-lid="Send Feedback">Send Feedback</a></li><li class="terms"><a target="_parent" href="/terms" alt="terms" name="&lpos=Navigation - Connect&lid=Terms of Service" data-lpos="Navigation - Connect" data-lid="Terms of Service">Terms of Service</a></li><li class="privacy-policy"><a target="_parent" href="https://www.nbcuniversal.com/privacy" alt="privacy policy" target="_blank" name="&lpos=Navigation - Connect&lid=Privacy Policy" data-lpos="Navigation - Connect" data-lid="Privacy Policy">Privacy Policy</a></li><li class="partner"><div class="partner-text">Visit our partner site</div><div class="connect-brand"><a target="_parent" href="http://www.telemundo62.com" alt="Duopoly" target="_blank" name="&lpos=Navigation - Connect&lid=Duopoly" data-lpos="Navigation - Connect" data-lid="Duopoly"><img src="//media.nbcmiami.com/designimages/WWSI.png" alt="WWSI"></a></div></li></ul></div></div></li><li><div class="nav-border"></div></li><li class="nav-small-section nav-search"><div class="nav-small-item"><div class="search-logo"></div><div class="search-logo-close"></div></div><div class="search-container"><form action="https://www.nbcphiladelphia.com/results/" method="get" target="_parent" id="nav-search"><div class="search-field"><input type="text" id="transcript" placeholder="Search" name="keywords" autocomplete="off" /><div class="search-field-logo"></div></div></form></div></li></ul></div></div></div></div><script>
    var browser = navigator.userAgent.indexOf("Chrome");
    if (browser === -1) {
      document.getElementById("mic").style.display = "none";
    }
    function startDictation() {
      if (document.getElementsByClassName("search-logo-close")[0].style.display != "block") {
        if (window.hasOwnProperty('webkitSpeechRecognition')) {
          document.getElementById("transcript").placeholder = "Listening...";
          var recognition = new webkitSpeechRecognition();
          recognition.continuous = false;
          recognition.interimResults = false;
          recognition.lang = "en-US";
          recognition.start();
          recognition.onresult = function(e) {
            document.getElementById('transcript').value = e.results[0][0].transcript;
            recognition.stop();
            document.getElementById("nav-search").submit();
            document.getElementById("transcript").placeholder = "Search";
          };
          recognition.onerror = function(e) {
            recognition.stop();
            document.getElementById("transcript").placeholder = "Search";
          }
          recognition.onspeechend = function(e) {
    				document.getElementById("transcript").placeholder = "Search";
    			}
        }
      }
      else {
        document.getElementById("transcript").placeholder = "Search";
      }
    }
  </script></div></div><!-- End header --><div id="adBackgroundContainer"></div><script>
nbc.vidSection = ((nbc.section === "video" || nbc.section === "videos") && nbc.subsection ==="") ? true :false;
</script><link rel="stylesheet" href="//www.nbcphiladelphia.com/templates/nbc_v4_video_page.css?r=131804066" type="text/css" /><div class="adcontainer"><div class="ad-container"><div id="leaderboard1" class="adSlot adLeaderboard" data-sizes="970,66|970,90|728,90" data-ord="1" data-pos="top" data-module="" data-gptcollapse="true"><script class="insertAdMPS">
	var SLOT='topbanner'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
	</script></div><div class="ad-container-close"><img src="//media.nbcmiami.com/designimages/ots-double-arrow.png" /></div></div></div><!--// canvas \\--><div id="canvas" class="sports"><div id="body"><div id="bodyContainer"><div id="main"><div id="abTestHeadline" style="width: 963px;margin: 0 auto;display:none;text-align: left;"><h1 class="headline">Friday with the Phillies: Legacy of David Montgomery Lives On</h3><h3 class="dateline" style="font-family: Roboto;font-size: 0.8em;color: #969696;margin: 10px 0;font-weight: 300;padding-left: 5px;">Published 2 hours ago</h3><div class="socialNetworks-top"><div class="social-icon facebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.nbcphiladelphia.com/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html" onclick="window.open(this.href, 'facebookWindow',
			          'width=500,height=500'); return false;" title="Facebook"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-facebook fa-stack-1x fa-inverse"></i></span></i></a></div><div class="social-icon twitter"><a href="https://twitter.com/share?url=https://www.nbcphiladelphia.com/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html&text=Friday with the Phillies: Legacy of David Montgomery Lives On&via=nbcphiladelphia" onclick="window.open(this.href, 'twitterWindow', 'width=500,height=500'); return false;" title="Twitter"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-twitter fa-stack-1x fa-inverse"></i></span></a></div><div class="social-icon comment"><a href="#comments" title="Comment"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-comments-o fa-stack-1x fa-inverse"></i></span></a></div><div class="social-icon email" onmouseout="return(ETMouseOut());" onmouseover="return(ETMouseOver());" onclick="nbc.updatePrintCall(this);return(ET());" title="Email"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-envelope-o fa-stack-1x fa-inverse"></i></span></div><div class="social-icon print" onmouseout="return(PTMouseOut());" onmouseover="return(PTMouseOver());" onclick="nbc.updatePrintCall(this);return(PT());" title="Print"><span class="fa-stack"><i class="fa fa-square fa-stack-2x"></i><i class="fa fa-print fa-stack-1x fa-inverse"></i></span></div></div></div><div id="feature_background"><div id="investigation_header" style="display:none;"><div class="invBanner"><a class="invHeaderImage" href="/investigations/NBC-Investigations-429434393.html" style="width:1010px;"><img src="https://media.nbcphiladelphia.com/images/investigation_.png" /></a></div><div class="invHeader"><span class="invSubtitle"></span><div class="sendTips"><p><a href="mailto:NBC10Investigators@nbcuni.com?subject=Tip for the Investigations Team"><span></span>SEND TIPS</a><span class="phone"></span></p></div></div></div><div id="feature_top_header"></div><div class="topArea"><ul id="topNav"></ul><form action="//www.nbcphiladelphia.com/results/" method="get" target="_parent" id="video-search"><div class="search-field"><input placeholder="Search Videos" name="keywords" autocomplete="off" type="text"><input type="hidden" name="type" value="Videos" /><div class="video-search-field" style="display: inline-block;"></div></div></form><script type="application/ld+json">
	  	  	  {"duration":"PT2M21S","embedUrl":"https://www.nbcphiladelphia.com/templates/nbc_partner_player?cmsID=510992842&videoID=ybXDfsOz4jwU&width=600&height=360&turl=http%3A%2F%2Fwww.nbcphiladelphia.com%2F&ourl=http%3A%2F%2Fwww.nbcphiladelphia.com","uploadDate":"2019-06-07T19:19:26-04:00","@type":"VideoObject","name":"Friday with the Phillies: Legacy of David Montgomery Lives On","description":"David Montgomery&rsquo;s legacy lives on throughout Philadelphia: his alma mater, Penn Charter, in South Philadelphia where he got one of the Major Leagues' best ballparks built, and a ballfield named in his honor in his native Roxborough.","publisher":{"@type":"Organization","name":"NBC 10 Philadelphia","logo":{"@type":"ImageObject","width":"600","url":"https://media.nbcphiladelphia.com/designimages/light-bg-phi-logo_2x.png","height":"60"}},"@context":"http://schema.org","thumbnailUrl":"https://media.nbcphiladelphia.com/images/190*107/David+Montgomery+Still.jpg"}
	</script><div id="videoPgFeature" temprop="video" itemscope itemtype="http://schema.org/VideoObject"><div id="videoPgFeatureContent" style="display:block"><meta itemprop="height" content="325" /><meta itemprop="width" content="578" /><meta itemprop="contentURL" content="https://www.nbcphiladelphia.com/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html" /><meta itemprop="embedURL" content="https://www.nbcphiladelphia.com/templates/nbc_partner_player?cmsID=510992842&videoID=ybXDfsOz4jwU&width=600&height=360&turl=http%3A%2F%2Fwww.nbcphiladelphia.com%2F&ourl=http%3A%2F%2Fwww.nbcphiladelphia.com" /><meta itemprop="thumbnailUrl" content="https://media.nbcphiladelphia.com/images/190*107/David+Montgomery+Still.jpg" /><meta itemprop="uploadDate" content="2019-06-07T16:19:26-0700" /><meta itemprop="name" content="Friday with the Phillies: Legacy of David Montgomery Lives On " /><meta itemprop="description" content="David Montgomery&amp;rsquo;s legacy lives on throughout Philadelphia: his alma mater, Penn Charter, in South Philadelphia where he got one of the Major Leagues' best ballparks built, and a ballfield named in his honor in his native Roxborough." /><div id="featuredPlayerContainer"><span class="Sponsored"> Sponsored</span><div id="featuredPlayer" class="pdkRegion" data-ap="true" data-sponsor="false" 
     data-cid = "510992842"
     data-vid = "ybXDfsOz4jwU"
     data-length = "2:21"
      data-title = "Friday with the Phillies: Legacy of David Montgomery Lives On"
     data-desktopflashpid = ""
     data-thumb = "https://media.nbcphiladelphia.com/images/652*367/David+Montgomery+Still.jpg"
      data-contenturl = "//www.nbcphiladelphia.com/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html"
     data-isthisalivestream = "false"
     data-m3upid = ""
     data-timestamp = "2 hours ago"
     data-videomediaid = "1534270019513"
     data-fwpolicymarket = "39065394"
     data-syndicationallowed = "true"
     data-dfxpurl = ""
     data-contentsources = "Uncategorized"
     data-lengthms = "141475"
      data-fullsummary = "<p>David Montgomery&rsquo;s legacy lives on throughout Philadelphia: his alma mater, Penn Charter, in South Philadelphia where he got one of the Major Leagues\' best ballparks built, and a ballfield named in his honor in his native Roxborough.</p>"
     data-author = "NBC10"
 data-feature = "Uncategorized"
><div class="videoPlayButton medium"></div><div class="videoOverlay"></div><img src="https://media.nbcphiladelphia.com/images/578*325/David+Montgomery+Still.jpg"></div></div><!--alex  Video Release--></div><div id="videoPgAdRR"><span id="tp-ad-slot_300x250" class="_fwph freewheelRightRail"><form id="_fw_form_tp-ad-slot_300x250" style="display:none"><input type="hidden" name="_fw_input_tp-ad-slot_300x250" id="_fw_input_tp-ad-slot_300x250" value="flag=+fcai&w=300&h=250&envp=g_js"></form><span id="_fw_container_tp-ad-slot_300x250" class="_fwac"></span></span><div id="ad_rr_1" class="ad" style="height:250px;"><script class="insertAdMPS">
	var SLOT='bottombox'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
	</script></div></div><script>
if( typeof window["abTest"] !== "undefined" && !nbc.vidSection) {
    jQuery("#topNav, #videoPgAdRR, #video-search").remove();
    jQuery("#video").addClass("abTest");
    jQuery("#abTestHeadline").show();
} else {
    jQuery("feature_background").css('background', '#141414');
    jQuery(".adcontainer").remove();
}
</script><h3 id="leadMediaTitle">Friday with the Phillies: Legacy of David Montgomery Lives On</h3><div id="leadMediaSummary"><span id="leadDekFull"></span><span id="leadDekSummary"></span></div></div><div id="tbFilmStrip"><div class="placeholder-animation"><div class="first item"><div class="video gradient"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text last"></div></div><div class="second item"><div class="video gradient"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text last"></div></div><div class="third item"><div class="video gradient"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text last"></div></div><div class="fourth item"><div class="video gradient"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text last"></div></div><div class="fifth item"><div class="video gradient"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text"></div><div class="text-line gradient-text last"></div></div></div><div id="tbFilmStripCarousel"></div></div></div></div><div id="videoPgMore"></div><div id="article_0" class="article_elements  large nolead   "><style>
.large div.article.rightrail {
    height:auto !important;
}
</style><script type="text/javascript">
    var __csMarketIDValue = "1861572874";
    var __csMarketKeyValue = "67ed2dfc-f223-44f4-f9e9-6ebcf5490750";
  </script><div id="at_0" class="articleText" itemprop="articleBody"><div id="taboola-below-article-thumbnails" style="margin-top:50px;"></div><script type="text/javascript">
        if (document.cookie.indexOf("scroll0=") < 0) {
            window._taboola = window._taboola || [];
            _taboola.push({
                 mode: 'thumbnails-a',                container: 'taboola-below-article-thumbnails',
                placement: 'Below Video Thumbnails',
                target_type: 'text'
            });
        };
    </script><div id="taboola-below-article-text-links" style="clear:none"></div><script type="text/javascript">
        if (document.cookie.indexOf("scroll0=") < 0) {
            window._taboola = window._taboola || [];
            _taboola.push({
                 mode: 'hybrid-text-links-a',                  container: 'taboola-below-article-text-links',
                placement: 'Below Video Text Links',
                target_type: 'text'
            });
        };
    </script></div><div class="article rightrail"><div class="rail adunit rect1" data-size="300x250" style="position:relative;"><span id="tp-ad-slot_300x250" class="_fwph freewheelRightRail"><form id="_fw_form_tp-ad-slot_300x250" style="display:none"><input type="hidden" name="_fw_input_tp-ad-slot_300x250" id="_fw_input_tp-ad-slot_300x250" value="w=300&h=250&envp=g_js"></form><span id="_fw_container_tp-ad-slot_300x250" class="_fwac"></span></span><!-- \\ GPT 300x250 // --><div id="rect1" class="adSlot adRect" data-sizes="50,50|300,250|300,600" data-ord="1" data-pos="top" data-module="" data-gptcollapse="false" style="width: auto; height: auto;"><script class="insertAdMPS">
            var SLOT='topbox'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
            </script></div></div><div class="rail topstories"><h3 id="storyListHeader-0" class="rightrail title"></h3><div class="blackdivider1"></div><ul id="storyList-0"></ul></div><div class="rail weatherbug" style="margin: 25px 0;"><div class="rail weatherbug"><div id="top-stories-weather"><div class="weather-module"><div id="weather-module-data-0"><div id="processingWeatherLoading"><img alt="processing..." src="//media.nbcmiami.com/designimages/nbc-ajax-loader.gif"/></div></div></div></div></div></div><script type="text/javascript" src="https://www.civicscience.com/widget/jspoll/?elt=civsci-1861572874&tgtid=67ed2dfc-f223-44f4-f9e9-6ebcf5490750"></script><div id="civsci-1861572874" class="module-civicScience"></div><div class="rail adunit rect2" data-size="300x160"><div id="rectSmall1" class="adSlot adRectSmall" data-sizes="300,160" data-ord="1" data-pos="top" data-module=""><script class="insertAdMPS">
            var SLOT='bottomrectangle'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
            </script></div></div><style type="text/css">
         .newsletterSignupBox .nsForm {position:relative;}
         #nsAjaxLoader {position:absolute;top:0;left:0;background:url("//media.nbcnewyork.com/designimages/nsuLoader.gif") 18px 6px no-repeat #ffffff;width:270px;height:26px;z-index:1;}
         input.nsSubscribe:focus {outline:none;}
    </style><div class="newsletterSignupBox"><div class="nsBox"><h3 class="rightrail title"><a href="/newsletters"> NEWSLETTERS </a></h3><a href="/newsletters"></a><div class="blackdivider1"></div><h3 class="newsletter copy">Receive the latest sports  updates in your inbox</h3><form method="post" id="newsletterBox-0" class="nsForm" name="ns-subscribe-form" class="validate" target="_blank" data-nsHandlerKey = ""  data-nsTmpID = "8"><span id="nsAjaxLoader" style="display:none"></span><fieldset><label class="form-float"><input class="required nsEmail form-input" name="EMAIL" type="text" placeholder="Email" onfocus="nsu.clearSignup(this)" /><span class="form-float-label">Email</span></label><input class="nsSubscribe form-btn" name="subscribe" type="submit" value="Sign up" /></fieldset></form></div><div class="nsFooter"><a href="http://www.nbcuniversal.com/privacy/" name="&lpos=Newsletter Sign Up&lid=Privacy policy" data-lpos="Newsletter Sign Up" data-lid="Privacy policy">Privacy policy</a> | <a href="/newsletters/" name="&lpos=Newsletter Sign Up&lid=More Newsletters" data-lpos="Newsletter Sign Up" data-lid="More Newsletters">More Newsletters</a></div></div><div class="rail adunit rect1" data-size="300x250"><div id="rect2" class="adSlot adRect" data-sizes="300,250" data-ord="2" data-pos="bottom" data-module="" data-gptcollapse="false" style="width: auto; height: auto;"><script class="insertAdMPS">
                var SLOT='bottombox'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
            </script></div></div></div><aside><div id="article-comments" itemprop="comment"><a name="comments"><span id="article-comments-header">  Leave Comments  </span></a><div class="fb-comments" data-href="https://www.nbcphiladelphia.com/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html" data-num-posts="6" data-width="650" style="clear:both;"></div></div><div class="ad" id="ad_3"><div id="leaderboard1" class="adSlot adLeaderboard" data-sizes="970,66|970,90|728,90" data-ord="1" data-pos="top" data-module="" data-gptcollapse="true"><script class="insertAdMPS">
            var SLOT='topbanner'; var ADSINSERTED = document.getElementsByClassName("insertAdMPS");(function(a,d){if(!a||!window.mps||!mps._queue)return 0;mps._queue.gptloaded.push(function(){mps.insertAd(a,d)})})(ADSINSERTED[ADSINSERTED.length-1].parentNode,SLOT);
            </script></div></div></aside></div><script>
if( typeof window["abTest"] !== "undefined" && !nbc.vidSection) {
    jQuery("#videoPgMore").remove();
} else {
    jQuery("#article_0").remove();
}
</script></div><div style="clear:both;"></div></div></div></div><!--\\ canvas //--><script src="//www.nbcphiladelphia.com/includes/custombutton-1.js?r=-1179829599" type="text/javascript"></script><script src="//www.nbcphiladelphia.com/includes/videohub_desktop_require.js?r=1334659122" type="text/javascript"></script><script language="Javascript" >var js="0.0";</script><script language="Javascript1.0" >js="1.0";</script><script language="Javascript1.1">js="1.1";</script><script language="Javascript1.2" >js="1.2";</script><script language="Javascript1.3">js="1.3";</script><script language="Javascript1.4" >js="1.4";</script><script language="Javascript1.5">js="1.5";</script><script language="Javascript1.6">js="1.6";</script><script language="Javascript1.7">js="1.7";</script><script language="Javascript1.8">js="1.8";</script><script language="Javascript1.9">js="1.9";</script><script language="javascript1.1" type="text/javascript"><!-- 
var bb=new Image();var _ti=910;var _q="";var na=(navigator.appName=="Netscape");var ns=(navigator.appName.substring(0,9)=="Microsoft");var _qDate=new Date();var _r=(document.referrer.indexOf(getdomain(location))>-1?"":document.referrer);_q+="&5="+parseInt(_qDate.getTimezoneOffset());_q+="&35="+parseInt(_qDate.toString().indexOf("aylight")>-1?1:0);_q+="&6=510992842";_q+="&7=1748351";_q+="&8="+encodeURIComponent(document.location);_q+="&9="+encodeURIComponent(_r);_q+="&10="+encodeURIComponent(document.title);_q+="&11="+encodeURIComponent(navigator.userAgent);_q+="&12="+encodeURIComponent((na?navigator.language:navigator.userLanguage));_q+="&13="+((navigator.javaEnabled()?'1':'0'));_q+="&14="+encodeURIComponent(js);if(document.cookie.indexOf("cc")==-1)document.cookie="cc=t;";_q+="&15="+((document.cookie.indexOf("cc")==-1)?"0":"1");_q+="&16="+encodeURIComponent((screen.width+'x'+screen.height));_q+="&17="+encodeURIComponent(((ns)?screen.colorDepth:screen.pixelDepth));_q+="&18="+encodeURIComponent(Math.random());_q+="&19="+_ti;bb.src="https://s.clickability.com/s?"+_q;
function getdomain(a){var i=a.host.indexOf(":");return (i>=0)?a.host.substring(0,i):a.host;}if(self['setupalready']){var dosetup = false;alert('There are two $imware.tracker calls on this page. Please alert Client Services');}else{var dosetup = true;var hasonload=false;}//--></script><noscript><img width="1" height="1" src="https://s.clickability.com/s?19=990&14=0&6=510992842&7=1748351&25=0&18=0.8694125443507333"></noscript><script src="//www.nbcphiladelphia.com/includes/blockadblock.js?r=2042017172" type="text/javascript"></script><script language="JavaScript">

if (window.hasOwnProperty('nbcu') === false || !nbcu) {
  /* this is a fix for pages when ad blocker
     prevents AppMeasurement.js from loading.
  */
  var nbcu = {
    catchAll: function (attempted_function, args) {
      console.log('[NOAD_SUPPPORT] nbcu.' + attempted_function + ' ', args);
    },
    tl: function () {
      this.catchAll('tl', arguments);
    },
    t: function () {
      this.catchAll('t', arguments);
    }
  };
}

if (!nbc.showAdClips) {
  var removeAdClips = function (evtData) {
    console.log('removeAdClips', evtData);

    var newClips = [],
        regMatch = new RegExp('ads\\.freewheel'),
        clip = null;

    if (evtData.hasOwnProperty('data') && evtData.data.hasOwnProperty('clips')) {
      for ( i in evtData.data.clips ) {
        clip = evtData.data.clips[i];

        if ( regMatch.exec(clip.URL) ) {
          continue;
        }
        newClips.push(clip);
      }
    }

    if (newClips.length > 0) {
      evtData.data.clips = newClips;
    }
  };

  $pdk.controller.addEventListener('OnReleaseStart', 'removeAdClips', ['*']);
}

      nbcu.pageName="csn:phillies:video landing page";
  nbcu.pageType=""; // used for 404 Error message page only
nbcu_siteID="nbcphiladelphia";
nbcu.list1="taboola";
nbcu.prop8=nbcu_prop8; // division
nbcu.prop9=nbcu_prop9; // station market
nbcu.prop10=nbcu_prop10; // call letters
nbcu.prop21="510992842";// content id
        nbcu.prop22="Friday with the Phillies: Legacy of David Montgomery Lives On"; // content title
          nbcu.prop23="video";
  nbcu.prop24=""; // content group
nbcu.prop25=""; // author name
nbcu.prop26="06/07/2019";  nbcu.prop27="uncategorized"; //Content: feature step 3
        nbcu.prop28=""; //content source
nbcu.prop30 = "Philadelphia";
nbcu.eVar70 = "Jun 7, 2019";
  nbcu.prop48 = "desktop";
/* E-commerce Variables */
nbcu.events=""; // filled with an event # as needed - example event1, or event19
nbcu.prop3="sports";
nbcu.prop4="sports";
nbcu.prop1="videos";
nbcu.eVar1=nbcu.prop1;

// Xfinity Omniture Value
if(typeof xfinityOmniValue != "undefined") {
  if(xfinityOmniValue == "xfinity"){
    nbcu.prop29=xfinityOmniValue;
    nbcu.eVar29=xfinityOmniValue;
  } else{
    nbcu.prop29="";
    nbcu.eVar29="";
  }
}
var nbcSocialIcon = jQuery(".social-icon");
if(nbcSocialIcon.length > 0 && nbc.isMobile == "false") {
  var envTracking = "floating ";
  nbcSocialIcon.on('click touchstart', function (){
    nbcu.linkTrackVars="eVar7";
    nbcu.eVar7 = envTracking + "sharebar " + this.className.replace(/social-icon | /g,'');
    nbcu.tl(this,'o',nbcu.eVar7,null);
  })
};
var liveContext = jQuery(".live-context");
if(liveContext.length > 0) {
  nbcu.events = "event47";
}
blockAdBlock.on(true, function(){
    nbcu.linkTrackVars="eVar19";
  nbcu.eVar19 = "adblock true";
  nbcu.tl(this,'o',nbcu.eVar19,null);
});
if(typeof U == "object") {
  if(typeof U.sessionVideoPVTracker == "function") {U.sessionVideoPVTracker("pv");}
}
nbcu.eVar200 = nbcu.contextData['tve.did'];
</script><script language="JavaScript">
/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
      var s_code=nbcu.t();if(s_code)document.write(s_code)//--></script><script language="JavaScript">if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'!-'+'-')</script><script type='text/javascript'>
if(document.location.protocol=='http:'){
var Tynt=Tynt||[];Tynt.push('bXPZ-CXVur458Cacwqm_6l');

(function(){var h,s=document.createElement('script');s.src='http://cdn.tynt.com/ti.js';
h=document.getElementsByTagName('script')[0];h.parentNode.insertBefore(s,h);})();}
</script><script type="text/javascript">
  //<![CDATA[
          var _sf_async_config={uid:15527,domain:"www.nbcphiladelphia.com"};
              _sf_async_config.path = "/news/sports/csn/phillies/Friday-with-the-Phillies_-Legacy-of-David-Montgomery-Lives-On_Philadelphia-510992842.html";
                _sf_async_config.sections = "news,sports";
                            _sf_async_config.authors = "";
              //]]></script><script type="text/javascript">
    //<![CDATA[
      (function(){
        function loadChartbeat() {
          window._sf_endpt=(new Date()).getTime();
          var e = document.createElement('script');
          e.setAttribute('language', 'javascript');
          e.setAttribute('type', 'text/javascript');
          e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
          document.body.appendChild(e);
          //for newsbeat

        }
        var oldonload = document.ready;
        document.ready = (typeof document.ready != 'function') ?
           loadChartbeat : function() { oldonload(); loadChartbeat(); };
      })();
    //]]></script><div id="fb-root"></div><script>
    var api_key = "85ab812aa7574de43da6e627c9970950";
    window.fbAsyncInit = function() {
      FB.init({
        appId      : 'api_key', // App ID
        version    : 'v2.6',
        channelUrl : '//www.nbcphiladelphia.com/templates/channel.html', // Channel File
        status     : true, // check login status
        cookie     : true, // enable cookies to allow the server to access the session
        xfbml      : true  // parse XFBML
      });
      // Additional initialization code here
    };
    // Load the SDK Asynchronously
    (function(d){
      var js, id = 'facebook-jssdk', ref = d.getElementsByTagName('script')[0];
      if (d.getElementById(id)) {return;}
      js = d.createElement('script'); js.id = id; js.async = true;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      ref.parentNode.insertBefore(js, ref);
    }(document));
  </script><script type="text/javascript" src="https://platform.twitter.com/widgets.js"></script><div class="footer"><div class="footer-container"><div class="row"><div class="col--8"><div class="footer-nav"><ul><li><a target="_parent" href="/news" alt="News" name="&lpos=footer&lid=News" data-lpos="footer" data-lid="News">News</a></li><li><a target="_parent" href="/weather" alt="Weather" name="&lpos=footer&lid=Weather" data-lpos="footer" data-lid="Weather">Weather</a></li><li><a target="_parent" href="/investigations/" alt="Investigations" name="&lpos=footer&lid=Investigations" data-lpos="footer" data-lid="Investigations">Investigations</a></li><li><a target="_parent" href="/entertainment" alt="Entertainment" name="&lpos=footer&lid=Entertainment" data-lpos="footer" data-lid="Entertainment">Entertainment</a></li><li><a target="_parent" href="/traffic" alt="Traffic" name="&lpos=footer&lid=Traffic" data-lpos="footer" data-lid="Traffic">Traffic</a></li><li><a target="_parent" href="/contact-us/" alt="Contact Us" name="&lpos=footer&lid=Contact Us" data-lpos="footer" data-lid="Contact Us">Contact Us</a></li><li><a target="_parent" href="/on-air/contests/" alt="Contests" name="&lpos=footer&lid=Contests" data-lpos="footer" data-lid="Contests">Contests</a></li></ul><div class="connect-social"><div class="connect-subnav-title">Connect With Us</div><div class="connect-social-icons"><a href="https://www.twitter.com/nbcphiladelphia" alt="Twitter" target="_blank" name="&lpos=Navigation - Connect&lid=Twitter" data-lpos="Navigation - Connect" data-lid="Twitter"><i class="fa fa-twitter"></i></a></div><div class="connect-social-icons"><a href="https://www.instagram.com/nbcphiladelphia/" alt="Instagram" target="_blank" name="&lpos=Navigation - Connect&lid=Instagram" data-lpos="Navigation - Connect" data-lid="Instagram"><i class="fa fa-instagram"></i></a></div><div class="connect-social-icons"><a href="https://www.facebook.com/nbcphiladelphia" alt="Facebook" target="_blank" name="&lpos=Navigation - Connect&lid=Facebook" data-lpos="Navigation - Connect" data-lid="Facebook"><i class="fa fa-facebook-official" aria-hidden="true"></i></a></div></div></div></div><div class="col--8"><div class="footer-links"><ul><li><a target="_parent" href="https://publicfiles.fcc.gov/tv-profile/wcau" alt="WCAU Public Inspection File">WCAU Public Inspection File</a></li><li><a target="_parent" href="/employment" alt="Employment">Employment</a></li></ul><ul><li><a target="_parent" href="/send-feedback/" alt="feedback" name="&lpos=footer&lid=send feedback" data-lpos="footer" data-lid="send feedback">Send Feedback</a></li><li><a target="_parent" href="/terms/" alt="Terms of Service" name="&lpos=footer&lid=Terms of service" data-lpos="footer" data-lid="Terms of service">Terms of service</a></li><li><a target="_parent" href="http://www.nbcuniversal.com/privacy/" alt="privacy" name="&lpos=footer&lid=Privacy policy" data-lpos="footer" data-lid="Privacy policy">Privacy policy</a></li></ul></div></div><div class="col--8"><div class="footer-logo"><a target="_parent" href="" alt="logo" class="footer-nbcu" name="&lpos=footer&lid=nbc universal logo" data-lpos="footer" data-lid="nbc universal logo"></a></div><div class="footer-copyright footer-logo">
                      © 2019 NBCUniversal Media, LLC. All rights reserved.
          </div><div class="footer-copyright"><a id="_bapw-link" href="#" alt="AdChoices" class="leftTerms" target="_blank" style="cursor: pointer;color:#fff;"><img id="_bapw-icon" style="vertical-align: middle;padding-right: 5px;"/><span style="vertical-align: middle;">AdChoices</span></a><script type="text/javascript">
            (function() {
              var ev = document.createElement('script'); ev.type = 'text/javascript'; ev.async = true; ev.setAttribute('data-ev-tag-pid', 209); ev.setAttribute('data-ev-tag-ocid', 908);
              ev.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'c.betrad.com/pub/tag.js';
              var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ev, s);
            })();
            </script></div></div></div></div></div><!-- Begin comScore Tag --><script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035083" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script><noscript><img src="http://b.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" /></noscript><!-- End comScore Tag --><style type="text/css">
        #home .stack-wrapper .adMicro .mps-slot {width:100%!important;} #home .stack-wrapper .adMicro .mps-slot &gt; div &gt; iframe {height:40px!important;} #home .stack-sponsorship iframe {height:68px!important;}#globalRightRail .sponsorshipCat iframe{height:50px;}
      </style><script>mps.writeFooter && mps.writeFooter();</script></body></html>            